Quick question about head unit and TR app

Is it possible to have your head unit (Wahoo ELEMNT in my case) connected to the trainer (Kickr Snap) at the same time as the TR app?

I have the ELEMNT in “passive” mode but I’m unable to get this working because TR doesn’t see the Kickr. If I start TR first, then the ELEMNT doesn’t see the Kickr.


Hey Tony!

The Bluetooth connection of your KICKR can only hold one connection at a time, however, since the Kickr and the ELEMNT are both dual band, you should be able to pair via BT to TrainerRoad and via ANT+ to your ELEMNT.

To pair the KICKR via ANT+ to your ELEMNT, these are the steps outlined on Wahoo’s website:

If you continue having trouble, I’d recommend reaching out to our Support Team at support@trainerroad.com and they can help you troubleshoot :slight_smile:

1 Like

Thanks for the response @Bryce.

I’ve tried the steps and looked around Wahoo’s site for any other suggestions with no luck. I opened a ticket with them to find out if there is a way to “force” the ELEMNT to use Ant+ instead of BT. The pairing keeps defaulting to BT on the ELEMNT so I wasn’t getting anywhere. I’ll see what they say and reach out to TR, if needed. I’ll also post my solution (if any) here for future reference.

Appreciate your help.

1 Like

Follow up …

Wahoo’s response was to make sure TR was up and had the Kickr locked into BT before trying to pair the ELEMNT to the Kickr via Ant+. I was already doing that, so I went back and tried again.

The reason I was going in circles was because on the ELEMNT, I was selecting the “Forget Sensor” for the Kickr thinking that it was releasing the BT connection as well. Guess it wasn’t because after going through the “Forget Sensor” option, I powered down the ELEMNT. Once I restarted the ELEMNT and went through the “Add Sensor” option, the Ant+ connection worked.

So during my workout, I was able to use the head unit in Ant+ mode for the Kickr, HR, and Stages PM while TR was being used with a BT connection to all three pieces. I was hoping to use the Mode option on the head unit to switch to resistance mode during the rest intervals, but that didn’t work out because BT wouldn’t let Ant+ control the Kickr for more than a couple of seconds. Oh well. I was able to do other things with the head unit, so glad it worked out.

Thanks again, @Bryce!

1 Like