Wahoo Kickr not registering power on TR app

Hi all,

I was wondering if you could help. I recently acquired a used Kickr and tried to set it up last night. Although it paired on both the Wahoo and TR app via Bluetooth (and showed a strong signal in both), it didn’t register any speed or power when I started spinning the pedals.

It’s entirely likely that it may be a chronic issue - I was given it by my mate as it had a fault on it that meant it overheated at low cadences (I don’t really do any low cadence work), so it may have just given up the ghost (and it’s outside of warranty, so I can’t get it replaced). But the ~30secs I spent on it were amazing compared to my Vortex, so I’d jump at any chance of fixing it!



I don’t have the answer to your problem but would like to know why speed matters to you when indoor training? :man_shrugging:

Sorry - I was unclear.

I should have said registering everything (so speed, power etc). I just tend to check speed so that I know my trainer is paired correctly with the TR app.

Title edited to reflect this

So it doesn’t register power on your wahoo head unit either?

Close any other apps and devices close by using BT except the one running TR to see if it is connecting to something else.

Thanks for the suggestion - I have a Garmin, but presumably it would pick up the Kickr via ANT+?

Sorry I misread your message. I thought you meant your wahoo head unit, not the wahoo app.

What I’m trying to understand is whether the problem is just with the TR app or if other apps/head units arent displaying power either

Ah, ok. Both the TR and Wahoo apps pair with the Kickr, but when I spin the pedals, nothing registers on either app (so speed/power), even though it still shows as being paired. Hope that makes sense!

Everything seems to be working - flywheel turning etc etc. I’ve also tried restarting everything (phone etc) but to no avail.

Thanks for your help :+1:

Also, have yet to try the ANT+ connection, but unfortunately that wouldn’t work for me as I run TR off my phone rather than a laptop.

I had my first Kickr Core for 9 months before encountering the same problem. No problems pairing it with TR, Wahoo app, or Zwift. Flywheel turned just fine. But not matter how hard I pushed the pedals, power stayed at zero. After doing some research, I discovered I was only one of many that had that problem. Wahoo said it was a problem with the optical sensor. Since mine was under warranty, they replaced the trainer.

I suspected that might be the case. No problem - like I said, it was free after all.

Only issue is that, after having a go on it, I really want one now! :tired_face:

Maybe you could use a power meter and per match to make it work? Then TR would be reading the peer and telling the trainer to increase or decrease resistance. I don’t know if the trainer still needs to read its own power, but if you have a PM why not try?

Also, just give ANT a shot to be sure it’s not just a BT issue.

Power Match will not work until the trainer actually starts reporting power.

Agreed that doing any and all testing to find the issue is needed (BLE, ANT+, different apps, etc.) to see what parts work and those that don’t.

I don’t know the specifics, but some Kickr have light sensors that need to be cleaned for proper function. There are a couple of other small things to fix, but I don’t know them specifically, and they can vary with the exact model.

Which year/model Kickr do you have?

Judging by the diagram/black handle, it’s a 2014 kickr.

It was a bit grubby when I got it out of the box, so it’s a possibility the light sensor may need a clean (if it has one). Do you know where the light sensor would be if it has one?

Other than trying out ANT+, if anyone else has any suggestions then please let me know.