Problem with ERG ? Newbie Help

Hi everyone,

Hope all of you are safe during this pandemic . This is my first ever post so apologies if its long or not very clear .

I have a query Regarding ERG mode and the app .

Trainer - Elite Digital Qubo B+

Query - In ERG mode as the the resistance steps keep increasing technically the resistance should increase and the cadence drops but in both the Ramp Tests there was not enough change in the resistance and i had to increase my Cadence to match the Power Target . Eventually i ran out of steam as i could not pedal faster but i still had enough in my quads . For example ending up with a Cadence of almost 120+ but still not being able to match the power target .
Yesterday i did HAKU which had intervals on 20 second at 200% of my FTP and even with an Interval Cadence of 140 i couldn’t match my target .

When i use the MyElite app and set a watt target say 150 W i can feel the resistance increase and a dropped Cadence which i couldn’t feel in my Ramp Test on the App which means that the trainer is okay . I was in the Smaller Gear upfront and middle of my chain ring at the back .

Kindly let me know how to trouble shoot the same and get the correct FTP and complete workouts requiring such major surges in power .

Yesterday i did HAKU which had intervals on 20 second and 200% of my FTP and even with an Interval Cadence of 140 i couldn’t match my target .

Career - https://www.trainerroad.com/app/career/sidhu

Regards
Yash

1 Like

Are you sure you are in ERG mode?

The resistance should go up/down w/changes in the ride profile, all while your cadence remains the same.

Double check your TR settings (e.g., trainer is paired, cadence paired, etc…)

Ah well that’s what it shows in the settings . Should i change something here ?

1 Like

That looks good/right as far as I can tell.

Pick any workout and try holding a steady cadence. The resistance should change automatically when the target wattage changes.

If you’re still having issues, contact support@trainerroad.com

They can check their session logs and/or give you and specific details for your trainer.

1 Like

Fellow Elite Digital Qubo B+ user here, I had the same experience with the ramp test in Erg mode after I’d been using the trainer (successfully) for about a year. Contact Elite support, they’ll walk you through a bunch of diagnostics.

(I ended up solving the problem by upgrading to a new trainer, so I have no idea if the issue is fixable.)

2 Likes

Hi all

Whilst I haven’t got the same trainer, I’ve had exactly the same problems too and am in the process of running through support to get it solved.

Two things that seem to kind of work are:

  1. Disabling power match. Seems to me a bit of a rubbish compromise.
  2. Forgetting the trainer and the power meter in the app and then reconnecting them. This worked perfectly for me the first time but then, last night, it was back to normal with ERG mode not really responding.

I am pretty sure that with certain trainers/connections there is a fundamental problem with power match. You only have to look at the thread on the matter to get this. It’s just frustrating as it renders ERG mode almost useless for me

1 Like

Make sure the MyElite app isn’t already running…

1 Like

Ah yes I ensure only one app runs at a time .

+1 on emailing support
I had a similar issue when I got my Kickr Core. Wasn’t sure on the setup etc and the ramp test didn’t have big enough power jumps for me to work out if it was working as it should. I ended up emailing support as my graph showed very close to the target for 15min or so then bigger gaps after that. Outcome was my power meter was losing connection (subsequently worked out batteries needed replacing) but this meant power match didn’t work. The TR support team got back to me within 24hrs, had analysed my ride and told me exactly what was going on. Not sure this is the same issue your having but hope it helps

1 Like

Hey fellow Qubo user , I’ve just dropped a mail to the support team let’s hope they come out with something conclusive. Because I can see in Myelite training app the resistance working , somehow just not catching up here with Trainerroad . Thanks a lot for the reply.

1 Like

Hey thanks for that reply . I’ve dropped an email to the support team as well with the same content hopefully they’ll be able to solve my issue .

1 Like

In case you do get a solution please do let me know . Thanks a lot

1 Like

Have you tried using it in Ant+ mode instead of bluetooth?

I don’t have the same trainer but do have an Elite brand one (original Direto) and found when I first got it the trainer would not work with Trainerroad in erg mode when connected via bluetooth and powermatch with my power meter that was connected via Ant+.

Once I went to Ant+ for the trainer connection it would work fine. Ditched the bluetooth mode and haven’t looked back. Note I haven’t touched the firmware in quite some time on my unit (since I got it 2 years ago so am not on the latest on for my trainer).

hello Sidhu,

I had similar issues, ended having to update the firmware on the trainer and fixed the issue.

1 Like

I guess I’ll have to order a ANT+ dongle then for my laptop and trt it with that . In the meanwhile I’m speaking to TR support as well hopefully something can be sorted .
Thank you for the suggestion

you should be able to update it through the app on the phone via bluetooth

I did try the upgrado app for Elite but that says my firmware is the latest