Planned workout not visible on Wahoo

Just got a new Wahoo Elemnt Bolt. I can push planned workouts to the Elemnt but then the screen for the planned workout is not visible. Did somebody have similar experiences?

Are you positive you have the workout page turned on in the Elemnt app?

And IIRC, you can load the workout on the device info screen on the Elemnt, so might check there too?

1 Like

Once powered up, you need to press the power button once. There is an item called “Planned Workouts.” Go there. If it isn’t visible, press the bottom middle button (SYNC) and it should show up. If it still doesn’t show up, make sure you are connected to a WiFi network. You do that from the phone app.

Once you load a workout, the planned workout screen becomes visible.

It’s really nicely done. You’ll enjoy it!


Hi, yes, this happened to me many times, the automatic push from TR to Wahoo does seem to be instable sometimes.
I usually then just push the same workout manually from the websites workout page to the wahoo.

Dear all. Thank you for your feedback.
I can push the workout to the wahoo bolt. It even changes laps automatically.
I just cannot see the screen for the workout with the curve of the workout at the bottom and the << >> for the middle button.

1 Like

Have you checked the “Pages” settings in your Wahoo Elemnt App when your bike computer is connected? Is it switched on?

1 Like

I have tried all this already. Just 2 hours ago I managed to solve the issue:
The solution was to remove the Bolt from the app and then do a full reset.
Now it works at it should.

1 Like

I had the same issues as you and I found your post this morning. I followed what you did and it’s back working now.

1 Like

Glad you were able to find help here!
Please be sure to post again if you have further or persisting issues with this. As both the TrainerRoad and Wahoo software changes, the troubleshooting steps may change as well, and we’ll work to provide the most up-to-date info here on the forum as it becomes available!

Thanks again. :slightly_smiling_face:

1 Like

/s Looks like Wahoo’s plan to make SYSTM the only training app compatible with their products has begun.

i have also ran into this issue multiple times in the past. The workout is synced to my device, i can select it from the wahoo menu on the computer but it does not actually select the workout for some reason. I had to do a factory reset on the device again to get the planned workout to actually function properly and give me the proper planned workout page once it was selected so i can see my power targets and interval times as i should be able to. seems like a software bug on wahoo’s side.