New Strava Route Builder?

Has anybody seen/used the new Route Builder on Strava? I’m still seeing the older version. Any way to force the new version to load?

Try this link?

https://www.strava.com/routes/new

Still shows me the old version. I even logged out/in and used a different machine.

Does yours say “beta” in the upper left corner?

OK, me too actually (went back and looked at DCR’s “Old/New” pics. I wrongly assumed the “Beta” tag seen was the new one.

Mine via the link I shared:

1 Like

Oh, me too lol.

The release stated the new builder would be coming over “the next few months”, so who knows when we will actually see it :man_shrugging:

2 Likes

Got all excited after reading DC Rainmaker’s review, but no go so far.

1 Like

Still not great for off-road planning. Missing trails, etc.

I tried the Komoot thing that someone mentioned, it seems to work much better. I’d say even better than RWGPS. It does seem a bit slow though, and I like how options are given, for route selection.

1 Like

Never used Komoot. How’s the interface? Easy to use or does it take some getting used to?

I’ve only used it once, and didn’t export my route, but here’s my $0.02 on this limited exposure.

It’s easy to use, but it takes a bit more clicking as each click says “add to course” or “extend end point.” Most of the time it’s the latter, the former for altering a course. The maps are based on OSM, from what I can tell.

RWGPS has some problems plotting mixed terrain courses, but Komoot got it and didn’t try to reroute my click miles out (which RWGPS did) to go around a park.

The backend operations, though, seem a bit slow. Compared to RWGPS, it seems to take a second longer or so. Not timed, no data, just perception.

I have this problem with Strava all the time, so that’s good to know. Thanks for your input! Honestly, none of these routing software are all that fast anyway so a bit of lag won’t really bother me as long as I’m getting routes that don’t try to route me over a river with no bridge (thanks Strava :unamused:).

My Strava was showing everything old until about 30 minutes ago. I’m seeing the new Routes now. I’m not a subscriber so it’s behind a paywall, but can see a few things:

3 Likes

LOL. Strava couldn’t even build the route I was planning on as the trails aren’t on their map.

RWGPS, when I get on the trail, would tell me, “leave the park, go 6 miles on highway to go around, and come back on the other side.” Um, thanks, but no…but if I click 2mm closer, hey it connects. Random weirdness. No problems with Komoot though, so far. I need to check their export to see if it actually works with my Garmin, though. Fortunately, I do know the route, just need to see elevation and mileage, to plan support/food/etc.

Crazy timing on this all, I shared the pic above (old site), and look what I just got by revisiting, as a “subscriber” (new site)…

1 Like

It sounds like DNS cache issues, or they didn’t update.

I see the same thing now. I’m not a subscriber, as I subscribe to RWGPS for routing and export.

Just got the new version!

1 Like

That for me sums up strava: you need a link with “new” to reach it, after it is announced. huh?

Clicked two points and it broke anyway. Back to RideWithGPS.

1 Like

Working fine for me. Just played with a new route and editing an existing one and working as expected.

2 Likes