Neo 2T ERG Issues using TR App and Zwift at same time

I seem to be having issues when running 2 apps at the same time and using the Neo 2T. TrainerRoad on my Andriod connected by ANT+ and also connected to Zwift ATV connected by Bluetooth. (trainer control disabled in Zwift. Running ERG mode, the TrainerRoad app controlled the trainer for the first interval but after that, would not control the trainer. Checked that zwift hadn’t stolen control and it hadn’t.

Restarted the TrainerRoad App, restarted the workout, still no trainer control in ERG?

In my experience with TACX products connecting anything over bluetooth will stop the trainer responding to ANT+ commands though it will still broadcast power.


I only have two rides on my Neo 2T but I can confirm that I have not had that issue when connecting TR via BLE and Zwift via ANT+.

1 Like

Yup, if I connect to my PC via ANT+ I have no issues. However, when I connect the other way round…TR to ANT+, Zwift via Bluetooth can’t get it to work.

1 Like

I’ll try reversing the the protocols during my workout tomorrow and let you know if I experience the same thing you and brenph have.

1 Like

Not a 2T, but a Neo 1 instead. I run ANT+ to TR and Bluetooth to Zwift. No issues. I make sure to get TR set up first. Then, I start Zwift and enable Bluetooth.

I have done it the other way around w/out issues, but prefer this since my bike PM is ANT+ only and TR does not fully support the bridging of the Viiiiva HRM.

1 Like

I swapped the protocols for tonight’s workouts with Bluetooth for Zwift and Ant+ for TR on my Neo 2T.

Initially, I connected Zwift first and then TR. Even though TR was receiving data, it was not controlling erg mode. I then restarted Zwift and erg mode started working with TR controlling it. It seems @KickrLin’s protocol of connecting TR first is warranted but otherwise the combination seems to work.

@Chester_Grimpeur perhaps your ant+ connection is dropping out on occasion causing TR to loose priority. I’ve found the ant+ signal can be fickle indoors with lots of rf interference around.

1 Like

It also might be worth double checking that the firmware is up to date. I have the Neo2, and it was having connectivity issues until I did an update (you would think that they could send out an email or something?) No problems after that

1 Like

Thanks. I tried this myself today. TR on PC (Ant+) worked fine. As soon as I put on Zwift, erg stops. Turn off Zwift, Erg restarts. It’s weird. It’s definately something to do with ATV. I can run TR on my phone, (or xert on my ipad) and connect to Zwift on my PC no problem. Works fine. It’s just when I connect to ATV I have issues. I’m going to drop a note to Tacx support. Thanks for your help.

1 Like

If I’m using my Apple TV. The order of Zwift and TR makes no difference since they are running on separate devices. However, you need to make sure that Zwift is not pairing to your trainer for the “Controllable” or whatever it is called. If it does, TR will have erratic ERG mode and/or lose ERG control completely. I have had this happen several times after Zwifting w/out TR where I need to pair the Controllable Trainer to Zwift. Also, even if not paired for today’s session, it might still auto pair itself tomorrow when you don’t want it to (annoying Zwift “feature” introduced year(s) ago). Anyway, after you’re all set to go, double check the pairing in Zwift.

Thanks, it’s definitely not being controlled by Zwift. I deselected it and double checked when the erg didn’t work that it hadn’t reconnected. It hadn’t. I can drop the workouts into Zwift but it just adds another hassle in.