Frustration with running TR and Zwift simultaneously

I’ve been having problems with TR while running zwift in another window. I have the “Controllable” Kickr unit connected to TR and either my PM or Kickr only on Zwift. For some reason every once in a while Zwift will connect the controllable unit and ruin a interval. If not that, the intervals on TR will do strange things- sudddenly add 30watts to an interval or miss a rest break. Anyone have a solution to this or understand it? I would just use TR itself but the mileage is really inaccurate…

What device(s) are you using to run TR and Zwift specifically?

What connection protocols are you using for each (ANT+ / BLE)?

If possible, I’d try to use just the power meter in Zwift, as a hope to reduce the chance it will “regrab” the trainer. But I know a few friends who have struggled with some issues more recently. I can review what they said to see if I have more specific suggestions.

I run the two together from Windows 10, with Ant+ pairing to Zwift, and either BLT or Ant+ pairing to TR and controlling the trainer (Neo). No problems

But, i do need to be careful when pairing in Zwift, as if i don’t press OK before the end of the pairing countdown, then it will re pair itself as controllable trainer

I do seem to have a problem with Ride On’s not coming through on Zwift, but that is not the end of the world and i haven’t tested to see if it is related to running both at the same time. I can’t see why it would

3 Likes

Similar to @PotsieA, I start Zwift. Connect the Power, cadence, and HRM through ANT+, turn off controllable, and then start the ride. Then and only then, I start TR and connect everything through Bluetooth. I have to check Zwift every single time to ensure that it doesn’t connect to Bluetooth. It will randomly forget that I prefer ANT+. I also have to ensure controllable is off before I start the ride in Zwift. If I accidentally let It pass the pairing screen and then go back to disconnect controllable afterwards, I have the problem with them fighting.

6 Likes

You reminded me of something else - i always have the ANT+ dongles in the same USB ports. Both Apps get confused at pairing if they are in different ports on different days

2 Likes

It may change time from time but I think i’ve been doing P2M Power meter and Controlable Kickr for TR, then the Blutooth Kickr non-controble for Zwift.

1 Like

Cool. Seems the order of launching is one key detail. On my PC with only ANT+ connection, I do TR first, then Zwift.

But I know many others do Z and then TR with better luck, seems to be with BLE in those instances, but I can’t say that for certain.

I’ve done this order exactly in the past, but go a little further and turn off Bluetooth on my computer, then use my iPad or iPhone for TR. Completely separate the devices seemed to help a lot, and prevented the software from switching, since the computer couldn’t use bluetooth and the iPad doesn’t have ANT+.

2 Likes

Dual-run on Win10 is fairly common and quite stable. I do Z/ANT+ first, TR/BLE second, and no issue. At lease not anymore. Both apps are quite good at remembering sensors they last connected to. There’s anecdotal evidence of TR hogging BLE if you start it first and use ANT+. Z does not appear to hog the unused channel.

4 Likes

I’ve just configured this setup on Mac OS today thanks to this thread which was a great help.

I’m using an ANT+ dongle on Zwift and Bluetooth on TR. I found the setup to work best pairing on Zwift first than opening TR. Also pairing the ANT+ PWR connection rather than FE-C from the H3 to the ‘Power’ connection of Zwift stopped it trying to automatically connect and control the trainer and fight against TR.

1 Like

This is exactly how I do it. 90% of the time, I have no issues. Lord help me if I get impatient and open TR before Zwift pairs! :laughing:

3 Likes

Nothing more painful than being ready for a session, standing in your bib shorts fighting software! :rofl:

4 Likes