Kickr V5 flywheel

Hi, so hoping this isn’t a really dumb question…
Does the Kickr flywheel contribute any assistance in resistance mode? For example, I hugely overshoot my power target for the first 15 of (say) 30 sec efforts but struggle to hold off a downward spiral despite maintaining and/ or increasing cadence once I hit that peak. Obviously I then start madly changing gears, but I start pretty heavy to replicate a track gate start, so I don’t have a lot of gear to play with.
Training on my BT wind trainer never produces this effect, makes me work right through the effort.
So I’m thinking the weight of the Kickr flywheel takes over? Not really sure I’m explaining this very well.
I HATE erg mode, but maybe that’s the way to do it? But there’s a significant numbers lag when doing this.
What am I missing here??

Yes, the bigger the flywheel, the more you get an inertia effect from a fast spinning flywheel

You can fix this by changing the resistance level upwards and using the small chainring, which means the flywheel will be spinning slower


If you are using Bluetooth connection, try the “Standard” trainer mode. It is a more progressive resistance curve like fluid trainers (and outside riding). Try a setting from 2 to 4 for starters.

1 Like

I’ve got an earlier Kickr and mostly use standard/level mode = 2. That does a good job of replicating flat roads, which means you still need to work at smoothing out interval entries/exits.

Thanks for your suggestions… unfortunately the V5 doesn’t work in standard mode… PLEASE bring it back!!!
So maybe just try upping the resistance significantly? I don’t want to be borrowing assistance from the flywheel (that’s cheating!)

Bummer on the V5 STD fail. Forgot about that blunder by Wahoo.

Kick that resistance over 50% and you can find some effort and slow flywheel for sure.

1 Like

woohooo, Stangate here I come!

It does if you downgrade the firmware to v4.1.2. See here: New Wahoo Kickr 5th gen compatibility issues in resistance mode - #28 by dlec10

You’ll need to search around online for how to do it, it involves something ridiculous like tapping the wahoo image in the app 10 times to get the option to appear.

Thanks, I have seen this before but think its above my technology threshold!

1 Like

Fair enough - downgrading the firmware is a pretty poor workaround. I’m disappointed that I’ve had a ticket open with Wahoo since March and there’s still no movement on it :frowning:

One question, what do you run TR on? I believe when I was having the issue in the Windows app, support told me to try the Android (beta at the time) and it still worked there. I’m not sure if that’s the case anymore, I never use the app, but it could be an option.

I use my laptop (Windows), never used Android (it’s weird). I think the problem is compounded by my tech NOhow

1 Like

I have used my BT wind trainer for years, brutal and unforgiving but I love it.
I was sucked into a smart trainer because everyone seems to have one and think they’re fantastic… maybe I’m just too old school.
Anyone want to buy an almost new Kickr?