Kicker stuck in high power after interval

I’m relatively new to TR, been on for about 8 weeks. I’m having an issue sometimes with my trainer getting stuck in a high wattage after an interval is done. So say I do 120% for 30 sec, when that’s done it gets stuck in 120% when it should be 60% recovery, or similar. See screen shot.
I’m using one of the first generation kikr’s in ERG and the power reading is off my FSA Powerbox cranks. I run the TR app on my Samsung Galaxy S10e.
I tried some things and noticed if I disabled bluetooth it didn’t happen any more. Until today :frowning:
It also stops happening if I reboot the app.
Any ideas greatly appreciated.

I’m really sorry to hear that you’re regularly experiencing this issue :pensive:. Have you reached out to our Support Team yet? They will be your best resource for troubleshooting and resolving this issue. If you haven’t reached out yet, you can get in touch with us at

We hope to hear from you soon :ok_hand:.

Thanks Bryce, I’ll do that

1 Like