JetBlack Volt V3.0 Firmware issue, power connection drops every 56s

Installed the new firmware 3.0 on Tuesday evening. Oh dear what have they done, trainer maintains Erg but stops reporting power for 1-2 seconds every 56s. I noticed this on the first workout I did, then paid real close attention last night and took this screenshot during my workout because the dropout of 1-2 sec was too short to show in the workout overview from the day before. I’ve contacted JetBlack and looking forward to seeing what they have to say.

The regular nature of the dropouts is clear on the power graph below

1 Like

Thanks for the heads up, I haven’t installed it yet!

Could maybe also be a connection issue. Is this with bluetooth, or ant+

I’m using BLE to connect to my iPad, I think its very unlikely to be a connection issue because it cuts out for 1-2s every 56s precisely, almost as if it was by design.

I had this same thing happen when using my Assioma pedals to read power for the handful of times i’ve tried SYSTM… Didn’t check timings or anything as I wasn’t planning to stick with the software and was only using up a trial period, but i will say the graph on my sessions looked VERY MUCH like yours while using my Assiomas. After the last session where I witnessed this, I immediately ran a couple more tests… a short session on TR with the same pedals and saw no such behavior. I also ran another test using my Kickr CORE on SYSTM and didn’t experience the dropouts like that. I was also using ANT+ on my MacBook Pro, rather than BLE for all the above sessions.

IMO…Perhaps it’s more an issue with the software itself if it affects multiple power meters in basically the same fashion?

The last time the SYSTM app updated was the 4th November, none of my workouts had drop outs until I updated the JetBlack firmware.

JetBlack sent me an update this morning

“We have narrowed down the issues and are working on documents to fix these issues. We should have a document for this issue ready in the next 12-24 hours.”

JetBlack sent me a copy of the old 2.4 Firmware, renumbered as V3.3. Which has solved the problem.

1 Like

Lol, I think I will stay off doing an update!