Issue regarding Ipad mini gen 1


I’ve been using an Ipad Mini gen 1 with TrainerRoad app last year, and worked very well. Now it’s time to hop on the trainer again, and after logging in the app, it does not bring the workouts from the TrainerRoad calendar.

Any ideas on fixing this?


Hi Mine has never worked with my old Ipad mini gen 1. I thought it was to do with the Ios not being the current one but I’ve just looked and it say 8.0 or later. So it’s not that. Could be memory issues?

Nah… there is enough space.

I’m just having go at installing it as I type. I’ll let you know how i get on

Also, on the Iphone works very well. All the workout are pulled from the Calendar and displayed.

Bizarrely having had zero success loading it onto my iPad a couple of years ago. It now installed first time! It did take quite a long time though -10 minutes maybe. Sorry can’t be of any help really

1 Like

The support team will know! They can look at all your settings and fix ya up.
You can email them at, or submit a request online!

1 Like