Is there a way to add "Extend Cooldown" option to a custom workout?

Simple question and I suspect the answer is “no” since I can’t see how to, but I’m just checking to see if there is a way to add the extend cooldown option using the workout creator.

I was once offered this option at the end of one of my custom workouts and assumed it had been carried over from the original TR workout I has based my custom workout on - but I didn’t get the same option when repeating the workout strangely (I could have just mixed up two different workouts of course). Still the bottom line is I don’t get this option with the custom workouts I regularly use and can’t see a way to add it.

If it can’t currently be done then can anyone from TR comment on whether it might be in the pipeline?

Thanks.

I’m pretty sure I’ve gotten this on my custom workouts, at least ones that had a cooldown at the end, at least one of which I created from scratch (not a copy of an existing workout.) I think that this option is only given if the last interval is below a certain power. If your last interval in the workout is 90% FTP, you won’t be given an option to extend that. I don’t know what the cutoff value is. Since you can now skip ahead in workouts, at least you can test this quickly.

I think you may set the cut off value up in the top right hand corner where it says “Reset Level”. Whether it works or not I don’t know

That’s an interesting thought and does marry with my cool downs which tend to be above 55% FTP or so. Will give it a test - unless someone else gets in with a definitive answer first.

Thanks.

I’ll check the next ride I do but I know for a fact I had extend cool down option on my custom workout I did today. I’ll check my other workouts.

Reviving this old thread: Does anyone know (TR Reps?) if it is possible to add “Extend Cooldown” to custom workouts?

It is possible to do, I have this working on my custom workouts. I think that what is required is that the last interval needs to be ‘low enough’ intensity to be detected as a cooldown. (and maybe also ‘short enough’)
Just setting the ‘rest level’ higher than my final interval didn’t give me this option.
Remember that you can move ahead in a workout - pause the workout, then slide the current position to the end. This way you can test this without doing the whole workout.

1 Like

In order for the interval to be detected as a cooldown, it must be below the “Rest Level” set in the Workout Creator.

Nate covers the basics of “Rest Level” and pre-defined intervals here in this video. This link will take you to the timestamp where he starts talking about this topic:

Create your First Custom Workout with TrainerRoad

Cheers :ok_hand:

2 Likes

I finally revisited my workout where this wasn’t working like I expected, and figured out what was going on. I wanted to make a long steady-state easy ride that I could extend, say at 65% FTP. If I set the rest level above this, I don’t get an extend warmup or cooldown. It also seems to have the whole workout as one interval.
What ended up making it work is to have at least one interval above the ‘rest level’. With this I get the extend option again. The rest level also seems to control what segments are considered intervals.

2 Likes