I'm sure I'm doing something wrong (Problems with Tacx Neo not holding power during FTP test)

I attempted to do an 8min FTP test this morning. The first thirty minutes or so was perfect. As I started the first 8 minute interval, I shifted into a bigger gear and tried to hold 250 watts. I would hit 250 and slowly the power would drop. It went down to something like 190. I shifted again and hit somewhere near 250 and then it fell off again.

At this point I stopped and checked my settings. I had the system setup for resistance at 6% (whatever that means) so I switched to erg mode. The same thing was happening, up to 250 and then down to 180 or so. I tried resistance at 0% and I couldn’t even hit 250. I stopped at this point. I’m guessing I was supposed to set it to resistance 100% or something but at that point I was frustrated and decided to try again another day.

Any advise?

Thank you!

I’ve got a Kickr and had to play around with resistance setting before getting a valid 8 min test. In my case, ended up setting to 36%.

Might want to play around with resistance setting by using a non-ERG mode workout like this:

1 Like

Thank you! I never knew that workout existed.

Out of interest why r u doing the 8 min test? Why not do the ramp test in erg mode making sure you have TR controlling your Neo. That would solve the issue.
I assume u r also not running anything else (like Zwift) simultaneously as that program may be controlling the Neo which may explain things.

1 Like

I did the 8 minute test for two reasons. First I wanted to compare it to the test I took last year and second because I don’t do that well on the Ramp Test.

I did have zwift on too so perhaps that was the issue but I had zwift running off of my power meter. I’ll try again with no zwift.

Running Zwift simultaneously is not an issue per se as that is what I do. That having been said I know Zwift tends to pair the Neo as the controller which has caused me issues in the past. Just make sure they are both not counter acting each other. Like u say…try it with Zwift switched off to see if that fixes the problem


Frustratingly I’ve told Zwift to use my trainer (Kickr) as power only, and then during a future workout Zwift randomly switches and starts trying to take control of the trainer.

I found exactly the same so check it every time dependant on what I am doing… good luck and hope u get it sorted

I went with the simple solution - stopped paying Zwift and only record in TR :slight_smile: