Is my 7 month old tacx neo busted?

So I tried linking zwift while doing a trainerroad workout last week. I’ve done this in the past no problems, with it easily set up as normal in trainerroad on my android phone and zwift reading (not controlling) the power on my laptop.

This time things went kinda haywire and now erg mode no longer works on mytrainerroad/phone/trainer combo.

Thats half the problem and I’m still working with trainerroad support to try and get to the bottom of it.

My other issue is I have managed to get erg mode working on my trusty laptop. The problem now is the power is wonky! Last nights session was hit intervals, 30 on, 30 off and the power was kinda all over the place, the summary for each interval confirming the average power was routinely -8 or thereabouts.

Before ya’ll shout out ‘that’s normal! power shouldn’t be exact!’, I can tell you looking back at past sessions my power has always been within 1 watt for a given interval.

This kinda leads me to my overarching question - is my 7 month old, £950 super duper trainer just plain broken?

Can you link exactly the same workout as performed before and after your perceived issue, for review?

I can try…

Have you tried turning it off and on again? :slight_smile:

Zwift used to give me issues when going from erg mode to free mode - binned zwift off for trainerroad :rofl:

Gonna give Zwift a go now they have 20 minute crit city races. I don’t mind losing when I’ve only invested 20 mins instead of 90!

Yes.

I have tried turning it off and on.

Thanks.

Are you using the Neo’s power reading or a PM with Powermatch?

My Neo2T tracks the intervals perfectly but when I power match a Stages PM there is no way I could keep it within a watt, I’ve not seen anyone control their power that smoothly, hats off to you if you can though.

I use Zwift and Trainerroad all the time, just pair the trainer via BT to TR and either the trainer or Stages to Zwift but uncheck the controllable trainer box or both Apps will fight for control.

There are two things that come to mind. The first is the method of connection. The second is possible interference.

I sometimes have issues with my Neo that are related to the connection type. BT doesn’t play nice with multiple apps on the Neo2.
I’ve also had issues in the past with my Wi-Fi messing things up. 5ghz fixed that one and for some reason it doesn’t happen in my new place.

It’s a bad time to have a trainer die. I sold my Kickr Core in under 10 minutes on the weekend. People are desperate for training gear.
Good luck. Hopefully it’s just a connection issue.

No dude, I am not using powermatch.

I was fiddling again last night, trying to find something as unfortunately it doesn’t look like I’m gonna get anywhere with trainerroad support "have you tried powering down the trainer for minimum 30 seconds? “. Lol.

I have always connected via my phones app using ant+. Last night I connected using Bluetooth but the problem I had was I couldn’t see how to switch the ant+ connection off on th trainerorad app or my phone’s settings, so it displayed that it was connected to both, which did not make any difference.

I have contacted the place I bought the trainer from (wiggle UK) to ask about a full refund.

This feels kinda like the last straw with a trainer I have been disspapointed with since day one, to be honest.

Sorry to hear of problems.
Are you now just trying to get TR to work (rather than TR + Zwift)?

I had a similar problem last week, in fact, when I was going to do the ramp test. So that was a problem that had to go.

I use a laptop with an ANT+ dongle. Turns out the laptop had bluetooth turned on and when I started the app, the ANT+ dongle had jarred loose. By that time, the Neo had connected with bluetooth for some things and ANT+ for others, once I got it fitted again. Don’t know if that was the problem, but when I turned off bluetooth on the laptop, things went back to normal.

Yes. If I can’t get trainerroad working properly I don’t fancy my chances of getting zwift working alongside it too😅

1 Like

Thanks, I’ve had that issue in the past too.

Today’s workout is Donner, so some steady-ish 12 minute intervals using my laptop will be a better indicator of how my trainer is functioning.

I still have one more trick left to try - downloading the trainerroad app onto my wife’s phone and seeing what happens.

This stuff is kinda soul destroying. Tech is great when it just works but any problems and for me personally it’s just a huge source of stress!

2 Likes

Have you tried connecting it to the tacx app checking for software update ? if everything is up to date , then ride your trainer in the tacx app manually adjusting the watts ? than going back to trainerroad and connecting it see if it works ? just some ideas , i hope your problems are solved sooner rather than later :wink:

I’d be careful with updating. It seems that the Neo can get trashed and Garmin takes no responsibility for it, at least if it is the early Neo, like the one I have.

oh i see, best not to do this then !

Yes I did this when it happened.

Last night I had it connected via the tacx app. It connected fine.

An issue I had there is the app was reading the power from the trainer but not controlling it. I couldn’t find an erg on/off option anywhere which meant I couldn’t tell if anything was working as it should!

I gave up at that point.
.
For the record, this is a 7 month old neo 2t

Was this app not working? Tacx has two apps.

Your problem sounds connection based to me. I had loads of trouble with my Neo2 in my old place.
I also remember that the Tacx utility app doesn’t have an exit button. That can really mess with things if you’re using a Bluetooth connection and then try to connect with another app through Bluetooth.
I had really poor 30 second interval response when I had interference. You can try sitting your phone or laptop right next to the trainer to test that one.

Hopefully it’s not the trainer.

1 Like

Yes dude that’s the app I tried last night.

It was displaying the power I was outputting OK (presumably) but it made no effort to match what I assume was the target power - as displayed in your pic at 150 Watts.

Like I said, I don’t even know 100% that it was supposed to be in erg mode and match that 150 Watts because I can’t find any erg on/off options on that app.

Confused much!

I just jumped on the trainer and tried a few things using android and my laptop at the same time.
If the trainer is connected to TR via BT then it won’t work with the Tacx app. And vice versa.
One BT connection at a time. Probably a good thing considering all the problems I have with other devices that allow multiple connections.

Do you have multiple apps open at the same time when this happens.

PS. That app only does erg mode as far as I can tell. At least in the power based workout mode I was using in that pic.

1 Like