Huawei mediapad m5

Nothing go do with TR, but I cant connect garmin HRM via garmin ant+ dongle to my Huawei mediapad m5.
Anybody succeded doing this? Is it possible and how did you do it?

Make sure you have the apps in my screenshot installed. Use the ant+ tester to make sure everything is working ok. There is a bug in Android 9 that prevents built in ant from working right now. The dongles are not affected by it. Let me know if you need more help.

1 Like

Thanks for replying!

I have the apps, but no function!

ANT HAL Service not found, what is that?

All of that looks good. HAL is if you had a built in ant. I can see that the dongle is recognized, so everything on the pad is good. What HRM are you using?

1 Like

It’s Huawei…they are spying on you while you poo…run away, run away.

I’m using Garmin HRM-Tri, which works fine with my Fenix 3 HR! Cant’t forward from my whatch to pad either. Strange…

Is this acknowledged and being worked on? I’m annoyed by having to use Android 8 instead of 9 only because of this.

Im geting this message when trying. Any solution?

I loaded the app tonight after my ride and got the same result. Then I went into TR and disconnected my tickr. After that it connected fine. Not sure if this is because TR was still running that it had captured it in some way. I reconnected it in TR and then it connected fine in the app. Try disconnecting it from any app and try again. Sorry I can’t be more help.

They know about it on this is ant and xda. Not sure if it is known officially yet or not. I put in a ticket with samsung before I knew it was android wide. I doubt they are addressing it though.

1 Like

Ok, thanks for your help!

I did manage to get connection twice yesterday, but very randomly and many times I failed. Hopefully I will learn how to make it work mot often!

His this been resolved yet? I just bought the huawei m5 8.4 today and never knew about this issue!

1 Like

I have the same problem