ANT+ dongle not working?

Tried to do a workout todaty, and could not get my ANT+ dongle to work.

Did a ride in Tuesday, and it worked ok. Now both TR and Zwift can;t find the dongle. I am running Windows11, and looking in the settings (under bleutooth and other devices) both my ANT+ dongles have a green dot (which means that W11 detects them, I assume). But neither TR nor Zwift can find the dongles.

Turned of Garmin connect on the suggestion of Zwift, but that did not make any difference. Restarted teh PC, unplugged and replugged the dongles…no joy. Any one else having troubles?


when you say TR and Zwift can’t find the dongle, what do you mean? Do you mean ANT+ is greyed out in either or do you mean you aren’t seeing those ANT+ devices in your list of devices?

I have had this issues before when it was the devices. I would check in the Computer Management area and the devices weren’t showing up in the list. plugging and unplugging them and restarting the computer helped every time, but that assumes the dongles aren’t recognized. If it’s the devices that the dongles don’t see, that could be interference, it could be distance. I have both my dongles on an extender to get within a couple of feet of my trainer.

1 Like

I get this from time to time on my laptop if I just close the lid and put it in sleep mode. After a few days the laptop wouldnt ‘see’ the dongle. Now I always pull it out before closing the lid and reinsert it, and it seems to have solved the issue.

With the last (or might have been 2nd last) pc update (its also happened in the past), TR never recognised my ant+ dongle despite the laptop (Windows 11) having done so. It was just a case of restarting the TR app for me.

Was having the same issue - computer was recognizing the ant+ dongle was in the computer but TR/Zwift was not. Go into device manger and locate the ANT+ device (mine had a small yellow exclamation point next to it and in the properties said there was no driver installed, even after installing the TR driver). It gives you the option to look for a driver, which you can download and unzip from here. Tell the device manger to install the driver from the downloaded folder and then it should be good to go.