ERG and stopped working with iPad Pro

I have had nothing but problems with Trainerroad not working with my Wahoo Kickr V2 for the past two weeks. Kickr works fine with Zwift in ERG but fails to engage ERG at all on trainer road. Has got so frustrating Ive cancelled my contract with Trainerroad.

  • Have you contacted support?
  • When you say, erg mode isn’t working, can you change the resistance via the TR app?
  • Does the iPad make connection to the trainer at all?

Typically, connection problems are due to Bluetooth, e. g. that another device (your iPhone perhaps) grabs hold of the Bluetooth connection to the trainer. Those kind of problems have nothing to do with TR, it is just a consequence of the fact that most Bluetooth devices only support a single connection.


Hey there,

Sorry to hear about those troubles. If you’d still like to try to fix those ERG issues while your TR account is still active, here are some tips that might help:

  • Try unplugging your KICKR for at least 10 minutes if it’s been a while since you’ve done so. Ideally, leave it unplugged between workouts – this can help it reset between your sessions.

  • Make sure your KICKR’s firmware is up to date.

  • Ensure your KICKR is only connected to one device (your iPad in this case) at a time. If it is connecting/trying to connect with another phone/laptop/tablet nearby that you are not using to run TR for your training session, it may cause connectivity issues.

More Bluetooth Smart (4.0) Troubleshooting tips can be found here.

And always feel free to get in touch with if you run into any additional issues. We’re sorry to see you go – we’d be happy to work through this with you while your subscription is still active if you are interested in getting this problem solved!

1 Like

I’ve had problems with my iPad in the past with a previous training app keeping the ble connection with it. I sorted it by making sure evertime id finished using it a training app I closed the app fully by flicking it away off the screen, if you you know what I mean.

My wife and I each encountered a similar issue over the past week with our Tacx Neo 2Ts and Windows 11 laptops.

I was supposed to do harder intervals this evening, I started out the warmup and my power was supposed to be around 170 watts. No matter how much I tried or how fast I spun, I couldn’t get the power/resistance over 60 watts. I re-paired my ant+ receivers (two Tacx receivers), rebooted multiple times, and even tried calibrating my Neo, even though it’s not necessary. I gave up after an hour. I’m hoping the problem is on TR’s side and goes away on its own.