Erg mode not working anymore with Kickr Bike v2 Direct connect


Happy user of TrainerRoad, with kickr bike v2.
It worked well until a few weeks ago. But recently erg mode is not working anymore when using direct connection (ethernet).

Here is the result of my investigation:

  • TrainerRoad + Bluetooth/Ant+: Erg mode WORKING
  • TrainerRoad + Dircon: erg mode BROKEN, I can see watts but erg mode is not working (watts go up and down according to pedaling speed and gear, but it doesn’t adjust back to expected power and keep constant resistance)
    • I tried powering off/on the trainer, reinstalling Android app, cycling between standard and erg mode in the app, etc.
    • Same issue with my wife’s phone and her TrainerRoad account, so it’s not my phone.
  • Zwift + DIRCON: erg is WORKING, so it really seems to be a TrainerRoad-only issue.

Did somebody else notice a similar issue?
Did a recent app update change anything?

I currently use Ant+ as a workaround, but I was hoping to use DIRCON for stability again, that’s why I got the v2.

Have you emailed TrainerRoad or Wahoo support? TR does weekly app updates and Wahoo does them at different intervals as well. They may have inadvertently impacted this issue so they are the best people to check with for review.

Tue and Wed’s workouts this week I did not have ERG mode with my Kickr Core. First time I’ve had such an issue. Last night I ran my workout on my laptop instead of my iphone and ERG worked.

After seeing your post, I just went and checked ERG on my iphone again. It did not work. Then I disconnected my power meter (I was using Power Matching) and suddenly ERG began working again.

I don’t have my power meter paired with my laptop, so there was no Power Matching with it.

Are you using Power Matching? Something may have gone amiss on TR’s end with it.

No, not using power matching.