Wahoo Kickr - No resistance in Zwift

Hi all,

Since last Saturday, I’ve got this annoying problem with my Wahoo Kickr and Zwift.
It seems like Zwift can’t/ won’t change any resistance on the Kickr. So it’s like pedaling without a chain.

In TR the Kickr is working as expected. In ERG and in Resistance mode no problems whatsoever.
I’ve connected the Kickr via an ANT+ Dongle to my laptop.
I’ve tried the following things:
-Different laptop, same ANT+ dongle.
-Ipad connected with BT
-Laptop connected with BT
-make sure no other app / devices is connected to the Kickr. (is there a way I can validate this? )
-connect Kickr to Wahoo App and “forget” the device (read this somewhere)

I’m kinda out of options and it still isn’t working.

Hope someone can help me out.

First and most obvious check…. Trainer is set as controllable in Zwift?


Does it work ok in erg mode (so doing a workout) in Zwift

Do you have ANY other apps running on ANY other devices, I have a dedicated laptop for Zwift, and if I have the TR app open on my PC it will block the signal and make a mess of it

Which Gen Kicker is it ?

It’s the same with Hills an Flat, do you have your weight set correctly

I just bought a new Neo 2SE (in sale on wiggle, don’t judge me) and am having a very similar compared to my original Neo

Is the feedback setting at 0%

Can you capture a screen shot of your Device pairing screen and Settings screens from Zwift?

Have you tried unplugging the Kickr for at least 30 seconds, tripling checking that every device you previously connected to the Kickr is closed completely, and then powering back on the Kickr on only connecting it to Zwift on one device and see if it works correctly ?

1 Like

Erg mode workout mode same problem.

Disabled Bluetooth on the iPhone and iPad. Rebooted the laptop and started zwift without any other apps running.
Still the same problem.
Bit strange that I tried to use the kickr both for powr and as controllable. But when I perform a spindown. I’m getting a timeout error.

After testing. Started TR and everything worked right away.

1 Like

Thanks for the pics and info. From all of that, it sure looks like a Zwift problem more than anything.

Out of curiosity, I’d suggest pairing the trainer for power (not your pedals) and just doing another test in SIM and ERG modes to rule out the power meter as some factor.

After that, assuming it continues not working, I think you may be best to contact Z support.

@SaSha1103, on the off chance you haven’t sorted this issue yet, I just found this as part of the latest Zwift release notes… I don’t have any further details outside of what I read in this user comment on the Z forums from Janne, but perhaps this could be your issue as well???

Problem solved …for now…

I’ve reinstalled Zwift. Unpaired the Kickr from ALL devices in the house. Unplugged power for 30s and reconnected it to Zwift (no ANT module in laptop, just BT and no other connections to my Assioma’s). And it still didn’t work… Then i connected it with BT to my phone and the Wahoo app and performed a spindown. Disconnected the app (forget sensor) and restarted Zwift and it worked…
Plugged my ANT dongle back in and connected the Kickr via ANT and it still worked.
Closed Zwift and opened up TR and connected the devices back to TR and it worked as expected.
Closed TR and opened up Zwift and everything is still working…
Fingers Crossed that it will work next time I’m doing a group ride :smiley:
3 hours on Saturday and 4 hours on Sunday last week in TR wasn’t fun at all…