Elite Suito won't pair with iPad

I am using (or trying to use) an Elite Suito turbo, Assioma Uno PM pedal and Wahoo HR, and I have the TrainerRoad app on my iPad. When I first signed up to TR and did my first session, everything worked exactly as expected, no problems with pairing or data. Then for my second workout, the trainer didn’t pair (which I only realised when I had to change gear instead of using ERG). Last night I got all set up for a ride and the HR wouldn’t pair; then the PM dropped out after a few seconds.

I read on the help guide that things can only be paired to one device at a time, so I unpaired everything from the Elite, Wahoo and TR apps on my phone; the iPad then found the HR and PM, but still no turbo. Tried restarting the app, turned everything off and on, nothing. Tried pairing with my phone, nada. Even tried kicking some stuff and shouting at it, no dice.

I haven’t yet tried checking for an update on the Elite app, so that’s my next step this evening. Any other thoughts or tips?