Elite Suito resistance problem

Today I was doing workout on my Garmin Edge and Suito (as usual) and when I changed resistance from level two to level one, resistance somehow went too high (probably maximum) and I cannot change it. I’m chainging the resistance level on garmin (and also on myETraining app) and I can hear the sound but resistance is the same. I cannot calibrate it because i cannot get 30kmh…

What can I do?

1 Like

@blind76 …posted your message to the Elite Suito thread…its been quite for a while though but someone may have sum inside for you.

I forget what size it is but you can google it but when my Suito was new I couldn’t get speed up to calibrate it untill I googled the circumference size. I think the usual is 2096 for a 700c wheel but its a lot smaller like 1700

1 Like

I have it more than a year and everything was fine… i tried multiple ways to change circum. and calibrate but nothing happens…

1 Like

Maybe you’ve tried this, but you can check to see if the magnets are moving. The motor will still move but the magnets won’t. You can nudge the motors and they may move again. I’ve attached a picture. If they don’t move then it could be a board swap. Ive had pretty good luck with their customer service with a similar issue a while back.

2 Likes

They asked me to take a video of the magnets and I sent them but they still didn’t resposne. There is a sound but magnets are not moving… do you maybe know how many time do they need to send thet board (to EU)?

Im not sure if they work weekends but I usually got a response or two per day. The part took about a week to get here to the US. I think it was about 12 days total from my initial ticket submission until I got the part.

1 Like

sorry, man. Suito is a very problematic trainer. I had it before and returned it to dealer. problem is same as yours, resistance problem. If you google Suito or have a look at dcrainmaker review, reviews are mostly negative.

I have been using Directo since. But my next trainer wont be a Elite.

Email their support, they can be quite helpful.

And in the meantime see if it responds to their native app instead.

I contacted Elites support and they asked me to remove some panel and take a video of magnets positions while turning it on and after they saw the video they sent me the electronic board and instructions how to change it. I took me just a few mintes to do that and now everything works fine.

They have all the instructions and everything ready so it looks like standard suitos problem.

3 Likes