Early Access to iOS Beta: Updated TrainerRoad

I was wondering the same thing the other day

1 Like

I couldnt find this either!

Think this is to make the app compatible with the new AT features for the beta testers.

Makes sense for sure

I’ve been using the new app for a few months now. Overall really great experience.

Yesterday, I had the first opportunity to use the “Train Now” feature as it was a day with no planned workout and I had some time open up to do a work out.

It took me a while to find the “train now” feature. From Calendar, I hit the “+” button, and then selected workout, and it was the usual filter of finding a workout based on time etc.

I then went back and hit the main menu, and then workouts, and the “train now” option was there. It worked great, I selected the endurance option, and away I went. And upon completion - the workout shows up in my calendar.

My ask/request:

From the calendar page, when I hit “+” it would be great if that took me to the “train now” option.


Unrelated ask:

  • I’ll often start a work out and then think…hmmm… what is the point of this workout anyway, and then to read the description I have to pause the workout. I’d like to be able to read the workout description and have the workout continue in background.

Thanks for all the improvements … overall - everything works great

2 Likes

Just loaded the latest version and can confirm that this problem is now fixed. Thanks for all the hard work!

2 Likes

The latest (6 March) beta is crashing on launch on my iPhone XR. The first time I launched it I got a network permissions request that I OKd, now it crashes on launch every time.

Submitted the same feedback via iOS.

1 Like

Got this message with the beta app this evening. I’m connected to the internet just fine. Used the app today without any problem. First time I have ever encountered this issue.

Never mind! Turning off my iPhone and then turning it back on seems to have solved the problem.

Spelling error: “gekoppelt” should be “gekoppeld”

In Dutch maybe :thinking: :wink: But not in German. You’d use “verbunden”.

Initially finished Clouds Rest and showed me an IS of 2.76 and Tss of 610. (Strong :joy:)

This happened today. I’m not sure if it was the apps fault but it never happened before:

I did the whole workout but the middle part got cut out some how. Before the last interval the yellow status line moved back to the beginning of the workout and then I tried to advance it and it did t respond immediately but then I ended up in the last interval. I did sweat in the screen so that may have been the reason but it hasn’t happened in the regular app.

@Woolftirol

I was only born once in a century.

Come to think of it, I was only born once …

Hi, guys. Overall, the beta app is working great for me. A couple things to note:

  • There seems to be an issue where after completing a workout and then re-launching the app results in the completed work out to appear blurred in the UI.
  • The estimated TSS in the bottom right hand corner of the completed work out runs off the screen on my iPad.
  • My Favero Assioma Duo is now identifying itself using the ANT+ name over the Bluetooth channel. I believe this change occurred when I started using the beta app. Are you now using a different way of identifying the devices?

I have reported these issues through the test flight app. Just wanted to note them here too.

Thanks for all your hard work.

1 Like

Has there been any guidance/info on the power match responsiveness setting?

1 Like

Don’t touch it unless power match doesn’t work well for you.

If you turn it up, it will react more quickly but might overshoot. And if you turn it down, it will react more slowly and might undershoot.

But if you’re on a modern smart trainer you’re probably good (Kickr, Neo, Hammer, etc).

3 Likes

Hello

I noticed the beta app was posted to the App store and installed over the previous version for me. This is great to see the progress, but still have a question

I know some voiceover improvements were made and they are great for getting around the app, but once I tap load workout, the workout screen is not accessible with VO (at least not on my iPhone 6s). All the performance numbers like power, time, cadence, etc are covered by a ‘invisible’ button, so I cannot get it to read off any of the data. If I double-tap this button it pauses the workout.

Hopeful that another batch of VO improvements is coming soon now that the beta seems almost done.

Thanks
Paul

2 Likes

Hi there, I can’t see this being raised after a search but I appear to have lost all my ‘favorites’ that I’d starred in ‘workouts’.

Both my versions of the app updated today on iOS and also Android. I understand that favorites are unique to each device you access TR on but they are definitely missing from both.

EDIT - sorry I’ve just read the separate post by Pete in the announcements thread - carry on as we were :joy:

1 Like

Favorites didn’t sync with this update due to us changing app framework. :sweat:
We’ve always had a hard time syncing favorites between apps, and we faced a similar situation syncing them with this update. We’re going to work on a better solution for this and we’re sorry we didn’t make it happen for this update.

While we understand that our athletes like to repeat favorite workouts, it might not be the best way to get faster. Some of the workouts you like to do may not always be the most effective for where you’re at in your Progression Levels, so it may be worth checking out TrainNow instead of your standard ‘favorited’ workouts. Even if you’re not a closed tester for Adaptive Training yet, this uses the AT system to find the right workout in accordance with your progression. Pretty slick!

Using the new workout filters are also super helpful if you have a favorite workout type (short, shorts, bursts, etc.). We have some features in the works that will launch with AT that should help provide an easier way to find alternates to specific workouts, which doesn’t help the ‘favorites’ issue but will definitely help in workout selection moving forward. Sorry for the inconvenience!

1 Like