Early Access to iOS Beta: Updated TrainerRoad

Did my first workout today and it all worked really well. Didn’t have any issues with it at all. The workout was done in ERG mode and the trainer responded well. Layout was clean and crisp. My only comment would be that the writing summarising the end of the segment (as seen in the screenshot above) was very small and could be larger as there is space available.

Also my TSS doesn’t seem to align with what I have in the calendar but that seems to be on the PC as well so might be another issue.

it is easier to switch between ERG and resistance mode as well.

1 Like

Installed and logged into the app. Going through menus as I have a workout a little later. Noticed ride sync does not have any connections on the beta even though it is connected in my account. Maybe just a small thing but wanted to point it out.

Going to connect them to make sure they get uploaded before the ride. It would be nice to not have to click into the menu to see if ridesync connections are active on ios app as it would only be a little more scrolling.

3 Likes

Sorry for another post but I am assuming the tss graph you see online is not part of this?

If not is it possible to add the 6wk avg and 6wk daily average to this section? Probably more difficult but really nice to see this online. (Ignore the text box in the screen shot)

Will report anything else after I do my workout today and thank you for adding me.

2 Likes

I just installed via Test Flight and it did replace the app store version of the app.

1 Like

Same for me which I am fine with personally.

1 Like

Favorite workouts did not copy over from previous non-beta app

1 Like

same

1 Like

Same for me. The beta installation replaced my current production version. I’m not sure if it was said earlier in this thread, but a small orange dot next to the app name indicates it is a TestFlight beta version. My only installed TR app has the orange dot.

1 Like

Completed workout with no issues, but once completed couldnt find section to put in ride notes. When trying to edit workout after the fact to find notes section, app stalled on a blank screen when in edit ride screen. Had to force shutdown app to exit edit ride screen which was blank.

2 Likes

Another bug to report. Went to delete tomorrows workout as I was going to replace it with something else but it shows up as below and wont let me click into it. Refresh does nothing. Also when you delete and press save I was expecting it to go back instantly but used the arrow on top left.

Edit: if I back out of the app and then restart it takes it does the refresh correctly as intended.

2 Likes

Same, I didn’t get the option to keep the original - or it wasn’t clear. No issue though. Did you have to connect your devices again rather than the app and phone automatically connecting to them?

1 Like

I had to repair. Quick 15 seconds though for hrm, pm, and trainer.

1 Like

End of workout the calendar showed completed version and still to do. Force closed app and reopened and it was fine.

2 Likes

Same here

1 Like

Thank you everyone for all the feedback, we’re organizing issues and every report is extremely helpful! I’m updating our list and the OP right now. I’ll make a note in the FAQ about the replacing of your current production TR app.

I just added a bunch more athletes to the testing group, please keep signing up! I’ll continue to add through the weekend and you should have access within a day of applying!

Last request, we are really interested to see how your experience goes with the Workout Player. Please try some rides, and please use it exactly how you would normally. Thanks again for putting it through it’s paces, and keep the feedback rolling!

4 Likes

Workout today was good - couldn’t tell it was a beta. Only problem I had was I could not append a note at the end of the ride - I submitted a screenshot through TestFlight. I also really liked how you could look at going from erg to resistance without the workout stopping. That quick access is slick.

1 Like

I use my laptop for TR workouts, so I thought I’d test to see how the mobile was capturing a newly finished workout.

Once it loaded, a few minutes after completing todays workout, it only partially loaded. The graphic was a cool atmospheric haze fading into dark space, stats were accurate, but the workout wasn’t marked as complete and “Load Workout” was still an option:

I then navigated away from the calendar screen to workouts, or something else. When I came back, the workout was marked as complete:

1 Like

I had the same issue as JimA above, and also found that if the zoom portion was swiped to the data page during warmup and cool down, the “extend” button overlaps the text on the data page.

Otherwise, the workout worked great. Nice having the new power match algorithm on the iOS app. Can’t wait until it’s ready to use on the iPad too!

1 Like

Just did my first ride with the new beta app. Used the app as I normally would and there were only two things that jumped out to me that haven’t already been mentioned.

  1. When I went to calibrate my trainer (Wahoo Kickr), there was no green checkmark that appeared over the speed when it was time to spin down like there is on the desktop app. It took me a second to realize that I had gone fast enough since I was used to seeing that indicator.

  2. When in landscape mode, the only way to access the additional stats view instead of the graph is to tap the arrow. I think you should be able to swipe across as well similar to portrait mode.

Great work! Love the new app so far.

1 Like

Experienced a bug this morning trying to do a ride through the app.

Opened up the app and workout, connected trainer/HR then started pedaling but nothing happened. Verified devices connected and hit the start button, no power warning popped up. Unpaired then reconnected to trainer (side note the “resume ride” button at the top right doesn’t do anything), still no power reading. Force quit app then same display and duplication issues noted above appeared again. Refreshed and still showing issues. Opened workout again and still no power. I did verify that my laptop was connected by Ant+ since I was running Zwift at the same time so that isn’t the problem. Switched over to my laptop to run the workout and everything worked normally, noting I did run the new update for the desktop app.

For reference I use the STAC Zero Halcyon in case it’s a trainer specific issue.

EDIT: force quit the app and reopened post-workout to see if it fixed. Friday’s showed normal again but today’s was tripled.

1 Like