Cannot find ramp test on MacBook

I can find the ramp test on my iPhone when logged into TR but not on my MacBook. The other tests are there and I’m searching under All Workouts. Updated the latest version but no luck. Any ideas?

1 Like

It sounds like you have some filters on in your search.

In the Workouts section:

  1. Check that you are looking at the All workouts, and not selecting your Favorites, Teams or Custom
  2. Click on Filters and ensure that all the filters are turned off, you should see the number 1966 next to the filter icon, that’s how many workouts there are
  3. Make sure the text search bar is completely empty

Ramp Test should appear first on the list.

Yep, followed your recommendations but no luck. I’ve also tried to resync the workouts without finding it. It’s strange - I can find it on the website when I log in and its on my iPhone but it’s not on the laptop. I can’t find it in a search, either.

Very odd. What happens when you click on the Ramp Test directly from any of the Plans? Is it there and does it load it up?

It’s not shown. I’ve checked couple of plans and it seems that the first workout (as listed at is the ramp test but when I load up the plan on my Mac, that workout isn’t listed. It just starts with the next workout. I guess I’ll have to send an email/request to the higher authorities. Thanks for trying to help!

I did a ramp test this morning on a mac. No problems at all. Not sure why you can’t find it. Is it on your calendar?

I’ve done the test a couple of times this last spring and it worked fine. Didn’t plan to do again until recently and now it’s not shown. My old ramp tests show up on the calendar and in career - there’s just no way to select it now.

I think I’d uninstall the app and reinstall it. It’s easy to do and should just reset everything and pull down all the workouts again.

Can you see a historical one that you’ve completed? If so there is an option to load workout from there ( three dots in top right corner ). Your setup may be different though bc I’m referring to the iOS app.

Good idea Nikki - I see that historical ride and it gives me the option to ride but when I try to, I get the message that “no matching ride can be found”

So strange. I’m going to try reinstalling tomorrow - thanks again for the suggestions.

Figured it out. I just uninstalled the app and then reinstalled. It’s now there. And the entire interface is new, too. Updated graphics, etc. I had tried to update TR but looks like I just had to do a complete reinstall.




Same problem here. Already reinstalled the app on my Macbook twice and resynched the workouts. No way to find it… (highly annoying) It seems that i get a error on 3 entries when uploading (that’s at least what it says in the small bar below on the interface: ‘upload error on submission’).

Anyone who can help out?

Btw: i had already done the test once, but it has also gone from my career (not from the calender on the website though…).

Have you contacted