Can’t load ramp test - anyone else?

Looks like I’m missing my lunchtime workout slot as I can’t load a ramp test.

I’m getting an error on logging in, then a success, then a blank screen loading a workout.

Tried on iPad and iPhone.

Tried deleting app and reinstalling.

Tried WiFi and 5G.


1 Like

Sorry, but it loaded right up on my phone. I’d contact support.

1 Like


I’ve emailed them but the chat is offline

1 Like

Same issue for me :cry:

1 Like

What devices are you all using? I’m an apple user, and I’m just having coffee and surfing, so I can test in their ecosystem if needed. The one above was on my iPhone.

Ramp loads for me on Android.

Saw a server connection error briefly pop up. Maybe regional? I’m in the UK.

1 Like

US here

Ditto, US.

I can’t load my morning workout using ios. Looks like there was an update last night, hmmm…

1 Like

Same with me. Slow to load progression levels. Adaptations check never finished. Loading the workout got stuck on a blank screen. I also briefly saw the server error message.

Tried an iPad and an iPhone. I’m in Canada FWIW

1 Like

Hmm, looking towards iOS specific then.

Typical. I start my plan after an eight week break and take out the whole iOS user base! :wink:

1 Like

I’m seeing slow performance on opening the iOS app, and adaptations never finished, but I WAS able to manually open the Ramp Test on my MacBook.

1 Like

I am on Android and could not load the ramp test from the calendar, went to the workout library and it loaded fine… Also was seeing connection error on the calendar view and progression levels were not loading.


It’s back up and working normally now for me.

1 Like

…I hope it processes the ramp results okay…:scream:

1 Like

I am having all sorts of issues with PLs loading etc in the UK - don’t have anything planned right now but seems to be some server issues, keep getting the “nasty spill” page - says checking adaptations for a couple of minutes then crashes. Seems to be a server issue rather than any particular OS related as I am having those issues on my phone and browser. I can load workouts normally on Android if I search the library for them.

1 Like

There’s a larger issue TR are working to resolve. I had the same issue with iPad and iPhone this morning. I emailed support. Reply from them below. I was able to load my workout on my MacBook and got it done.

“Unfortunately, we’re having issues across all the TrainerRoad Apps and the Website. We have all hands on deck working to resolve this issue, and I’ll send you an update as soon as we make any progress.

Hang tight. We hope to have this resolved very soon.”


Thanks for the heads up @mikethg, and hope it’s not too serious.

My ramp was processed okay, so I’ll stop opening/closing apps and logging in :slight_smile: