Server connection issues

The Trainerroad app is continually trying to sync progression levels and when I try to load today’s workout, the screen goes black. I tried uninstalling and reinstalling the app but the problem persists (running app on Pixel 6). Is anybody having issues connecting to the servers this morning?

Yeap, seems so. Training levels are at 1 now for me :))

yes- i think we are all having them. i have seen it referenced in other threads this morning as well, ex:

hang tight guys! i’m sure it’ll be resolved soon enough. do a z2 ride if you need distraction :slight_smile:

Things do seem rather slow at the moment - I’ve been getting a few error messages along the lines of

Oops! Something went wrong. Please check your connection and try again. Contact support if the issue persists.

That’s on the Train Now page on the website.

Folks, we’re really sorry for the inconvenience this morning. Our engineers are aware of the issue and working full-time to get it fixed.


Are you kidding?

This gives me an excuse not to get on the trainer! :rofl: :rofl:


Yea i usually do the TR + Zwift combo, but with the TR issues this morning I resorted to the full Zwift experience. :wink:

Adaptive Training noticed that everyone needed a rest day :wink:.


I ended up setting my iPad to airplane mode and did my workout “offline”. Hopefully it will sync later when the service is back up.

There is an AWS outage that seems coincidental enough to be related. I couldn’t load a workout on my iPhone or iPad but the desktop app worked on my laptop.

1 Like

Someone in the other thread mentioned that you can get your workout to load if you load it from the workout library, not the calendar. Worked for me… (On Android)

I have the same issue -unable to load a workout - just get the doughnut of death on the ipad

So… is it back and running? :smiley: I don’t understand why my progression levels are all at 1 :)) Is it due to the new ftp tested?

Interestingly, 1) TR having problems, 2) Strava saying their loads were slow
… AWS having a severe outage… Coincidence? Anyway all seems sorted now.

I managed to loadworkout on PC and complete the session, despite the issues. I really feel for IT people in these circumstances with loads of users. Glad I left It many years ago.