ANT+ Issues on Mac Os (Mac Mini Late 2012)

Hi there… Few days ago i bought my first trainer (Elite Direto X), coming from my Kinetic Road Machine (also upgraded with ProFlyweel), which i was using with Favero Assioma Pedals using Sunto ANT+ Stick and connected to MacMini. Sometimes stick was not found, but simple unplug and plug again will solve the problem.

Now i realized that i have strange problem with my DiretoX connection (still did not try with Trainer Road), but i can see that problem with Elite MyTraining application and also ZWIFT.

  1. When i use ANT+ Connection to connect to trainer using Elite application, i can find it, also i can connect to cadence sensor or HR strap. But when i try to adjust Power Smoothing nothing… It’s just closing… When i try the same with Bluetooth connection all fine. Seem that even can connect trough ANT+ it dont work properly

  2. ZWIFT When im connected on trainer trough ANT FE-C i can find the trainer, but trying ERG mode workout dont work properly at all… Also in sim mode it’s not ideal. So same here… Even is connected trough ANT+ something is wrong and not work properly…

When i connect using Bluetooth everything fine (will test tommorow more detailed, i tried now just few miutes for a test, tired for proper test)

I also tried using USB extender (usb 2.0 1.8 and powered up usb 3.0 extender which i put it just few cm’s under trainer). Nothing changed.

I tried same ant+ stick on PC and Windows 7.Just Elite MyEtraining app, connected to trainer without problem, and done Power Smoothing without problem. I tried from Elite MyEtraining app Training test and can feel how trainer adjust the power. So working ok from the short test i done

Anyone else have ANT+ issues on Mac Os? (latest MacOs installed, and i use MacMini late 2012 model)

Still did not tried Trainer Road since i want to start in about 10 daysto be able to ride the workouts without missing so dont want to activate right now

I fear I cannot help you specifically, bit I can say that ANT+ in general works fine on OSX with TR for all features. I use it on and off with my MacBook. (BT for Zwift, ANT+ for TR).

Yea, ive had a lot of issues with ANT+ on OSX/MBPro, going back to the latest major overhaul to the desktop app (I forget the version but when there was a big UI change). I could only connect to devices via ANT+ if Bluetooth was off, but when I turned BT on to pair earbuds, devices would show up multiple times. This would happen with my HRM and TR would always pick an instance of it that was showing a static HR and ignoring another instance with my actual HR. Sometimes this would happen mid workout. TR would also not connect to my Kickr Core via ANT+ at all, so I had no way of avoiding the issue by turning off BT during workouts. It was a real headache that I never solved (haven’t tried in 6ish months, I run TR on an iPad now and everything pairs flawlessly via BT there).

If Ant+ isn’t working, but Bluetooth is, what precisely is the issue? AFAIK Bluetooth is the preferred protocol on TrainerRoad as you don’t need any dongles or so to get it running.

Sounds like the driver for that dongle is faulty. Can you update it?