TrainerRoad recognition of Ant+ Dongle

Does anyone else have issues with TrainerRoad often not recognising their Ant+ dongle? When I first load up TrainerRoad and plug the dongle in it almost never recognises it. It takes a series of restarting the app, unplugging and re-plugging the dongle for it eventually to work. When it finds it, it basically works perfectly, it’s just that initial frustration.

I’m standing here for about 10 minutes now trying to get it to pick up again. Anyone have anything I can try?

This is on a Mac laptop with the desktop app.

I use a Macbook Pro w/an ANT+ dongle. However, I have never experienced the issue you are having. What dongle are you using? Garmin?

Have you tried restarting the computer?
Try a different USB port?
Is OS X fully updated?

If none of the above are the fix, I would suggest resetting the SMC as well as resetting NVRAM.

1 Like

You can also go to: 🍎 => About this Mac => System Report => Hardware/USB to verify that the computer has detected it.

1 Like

Thank you, I’ll try a couple of these suggestions later. I really should have tried restarting; that would have been a simple thing to try. I tend to just close the lid so it’s probably not had a full restart in a while.

The dongle I’m using is an Anself, so I guess it’s a less premium product than the Garmin, but it seems to work when it works if that makes sense.

Computer is pushing 8 years old now so it’s starting to struggle a bit in general :confused:

1 Like

Thanks, that’s a good tip, I’ll try that later.

Have you looked through this article from our Help Center related to troubleshooting your ANT+ dongle?

If not, follow the troubleshooting steps outlined and let me know if you are still unable to connect consistently:+1:


Thanks for that Bryce, sorry I should have searched the help section first.

I worked through that page; I don’t think I have ANT agent - seems to have been discontinued looking at the Garmin website, but I did have Garmin Express running so this could have been the conflict.

I think quitting that and telling it not to open automatically has solved the issue. I’ve quit and reopened TR a few times and plugged in / out the dongle and it’s seems to be connecting consistently now. Thanks for your help!


I had a problem where periodically the Ant+ dongle would not be visible on my windows 10 computer. Plugging and unplugging didn’t work. Garmin Express was off. The only solution was to restart the computer. I have started using the TR beta version with native Bluetooth and that has been solid for the week I have been using it. Same with the Zwift native BT version. Getting rid of the dongle is just one less thing to worry about, break, or lose.

I’m so glad that helped sort things out!

Yeah I looked at using Bluetooth but my turbo needs at least BT 4.0 and my computer is old, so it would just mean another dongle required!

I’ve had similar issues with my Garmin Ant+ USB stick. It worked about 25% of the time for me on the old desktop app on Mac. I was usually able to get it working through some combination of 1) unplugging the stick 2) quitting the app and restarting and 3) exiting and reentering workout mode on my Garmin watch (broadcasting HR from there). The beta app is so much better, but can still be a bit fiddly — I find it works for me about 80% of the time now. Try the beta app if you haven’t! It’s way better than the old app on Mac desktop.