Workout creator

So sorry about the trouble @DarthShivious. I’d recommend reaching out to our Support Team so that we can take a closer look. You can reach us at

Looking forward to hearing from you :ok_hand:

1 Like

Thanks Bryce.

Switching users on the same Mac as suggested by BB above worked.

So seems like a local machine issue at my end. I can write it up for support but not sure it’s a good use of resource to chase.



Hey Mark,

I ran these commands in Terminal:

sky:~ bbarrera$ cd
sky:~ bbarrera$ find Library -iname "*air*" > files-air.txt
sky:~ bbarrera$ grep -i adobe files-air.txt
Library/Application Support/Adobe/AIR

And then I deleted the files/directory (showing command only)

rm -r Library/Application Support/Adobe/AIR

Started WorkoutCreator and had to accept Adobe Air license agreement. Then made a workout and published.

Try that, and if it doesn’t resolve then my next step would be to “rm -r” all three Adobe Air related files/directories under Library directory. And if that doesn’t work, I’d do the same find command but use “workoutcreator” and delete those (I get 3: two under “Library/Application Support/” and one under “Library/Caches/”).

Ask if you are uncomfortable working at command-line in

Tnx – Semi comfortable following directions and using terminal but beginner status for sure.

Here is what I get (deleted the mac ID and directory bits):

grep -i adobe files-air.txt
Library/Application Support/Adobe/AIR

So same three directories returned as you showed.
But… when I do the remove step I get:

rm -r Library/Application Support/Adobe/AIR

rm: Library/Application: No such file or directory
rm: Support/Adobe/AIR: No such file or directory


Space is a special character…

Try this:
rm -r Library/Application\ Support/Adobe/AIR

Or this:
rm -r “Library/Application Support/Adobe/AIR“


That deleted the directories.
Launched WC and got the AIR agreement dialog.
WC launches and…

Still get the keychain dialog box. Can modify workouts but when I try to “publish” it just keeps asking for the keychain info and no about of “cancel” ends that cycle.

Tried just the first directory and then all three. Same result.

No need to bash your head on this one, but certainly appreciate the effort and the linux lessons.


The other option to completely delete Adobe Air is to get Appcleaner, which makes completely deleting apps (including all of their directories) off of your Mac simple.

To use Appcleaner, all you do is:

  • Launch Appcleaner
  • From the Applications folder, drag the application you want to delete onto the launched Appcleaner winder
  • scroll through the removal window and make sure all of the folders are checked

Hey Mark, no worries I’ve been using Unix/Linux forever and could do this stuff in my sleep. Here is the cleanup sequence I would do:

  • delete Adobe Air stuff under Library/
  • delete WorkoutCreator stuff under Library/
  • try again

With a quick search, I didn’t see any Air or WorkoutCreator items under Keychain.

The big difference between your normal account and the new user was the items under Library/ and possible some hidden “.” files in your home directory. Didn’t see any possible hidden files in my home directory, and so I really think it should work if you just delete the saved files under Library/ because that is where apps save your settings like username and other stuff that is uniquely used by you when using the app (versus another user on the computer).


@DarthShivious and on my box that cleanup would look like this (make sure is not running):

sky:~ bbarrera$ rm -r "Library/Application Support/"
sky:~ bbarrera$ rm -r "Library/Application Support/CrashReporter/WorkoutCreator_2CBA08DE-68C2-5134-A8F1-723D3CFB5A58.plist"
sky:~ bbarrera$ rm -r "Library/Caches/"
sky:~ bbarrera$ rm -r "Library/Application Support/Adobe/AIR"
sky:~ bbarrera$ rm -r "Library/Caches/com.adobe.air.Installer"
sky:~ bbarrera$ rm -r "Library/Caches/com.adobe.air.ApplicationInstaller"

Just did that on my system and launched, accepted the Adobe Air agreement, logged back into WorkoutCreator, and waited for WC to download 2080 workouts. Then pulled up Baxter and made my own Baxter +11 version.

1 Like


If you aren’t tired yet…

What is the command to list the trainerroad workout creator files? I guessed sytaxed for the Find and grep revealing these but not the “.plist” file

Find Library -iname “workoutcreator” > files-workoutcreator.txt
grep -i trainerroad files-workoutcreator.txt

Library/Application Support/

seriously I’ve had Linux command-line in my dreams for decades LOL

find Library -iname “*workoutcreator*” > files-workoutcreator.txt
1 Like

Cool - I guessed it correctly. Not finding that .plist file, just the other two.

The scary part is I’m remembering how to do some of this stuff but will not get the syntax correct flying solo so mucho gracias



Thank you very much for the time on this. Was fun too.


@Bryce (this might be helpful for others)



Is there any relase date yet for the new workout creator?

1 Like

Hi, George! It’s on the roadmap, but still with no eta while our developers are working on higher priority issues. Sorry I don’t have better news, but is there a specific feature or aspect of WC that isn’t working for you that we can maybe help address in the meantime?


Its simply the fact that it needs Adobe air to run which is the issue. And its known to have some issues such as when duplicating a workout numerous are created. But the fact it needs air is my biggest issue. Thanks

1 Like

Oh sure. The new version of Workout Creator will not need Air, I’m sorry there’s not a workaround for it now, or a timeline for that update. It’s definitely on our roadmap though, thanks for your patience! :crossed_fingers:


WC is cumbersome and outdated. I have been contacting customer support for about 2 years on it. A couple of months ago (most recent exchange), I provided a list of the key features that are needed. The TR suggestion was to use Training Peaks to develop your workouts and then import them. What TR may not fully appreciate is that WC is part of a larger set of needs for the segment of the market that understands structured training and has the skills to develop our own workouts. Too much to explain here, but I hope TR does not continue to push WC out indefinitely.


Thanks for checking in, I’ll go ahead and nudge the development team that athletes are asking about this update. Thanks for discussing those features with our support team, it helps us tremendously as we start to fine-tune those changes!


I really like the workout creator function. I have been playing around with it and have just created this 4 x 10min workout:


… ran the same commands, at the terminal, also deleted the workout creator from my Apps folder, - reinstalled the workoutcreator.air file
opened workout creator… still getting prompted for key file password, not accepting it… but if I click deny it closes, asks me for my TR credentials which it accepts and then allows me access to WorkoutCreator.
Created a workout and published,
confirmed its published by access TR from a iPad

More a howto… build workout.

Anyone do Anaerobic tests using a TR, have a max power for 10 sec, 1 min and 5 min I need to do and wonder how.