Wattbike Atom not working in Erg mode

Really frustrating issue. Was doing V02 when power started fluctuating or not ramping up. Then dropping down.

TrainerRoad support was fast and precise in responding (thanks Ian) saying known Wattbike Issue (Bluetooth with iPad) that’s fixed in latest firmware. I’m using latest firmware and the problem persists. This renders TrainerRoad unusable.

Raised a ticket with Wattbike four days ago. Posting here to try and elevate the issue and see if anyone had any ideas.


Did you resolve the problem mate? I’ve got the same problem

In a roundabout way, yes. I swapped to a PC and ANT+ (which worked) and after a few weeks and an updated firmware (or maybe I swapped to beta firmware) it worked.

Good luck

Cheers for reply. I’ll try that

Was this a bluetooth issue? I’m having this problem with my Atom having swapped from a wahoo kickr. Just deciding wether to get an ANT + dongle and try that!


I’ve a Wattbike Atom and have been using Trainer Road for about 6 weeks now, initially I found that the odd workout the watts were fluctuating at the start of the workout as the OP has described and had to stop and delete the workout and start again, (the fluctuations occur from the get go).

I use the Atom using Bluetooth paired straight to PC and Windows 10, I discovered that going into devices on the app before starting a workout to see if the app has the devices properly paired ( I use the Atom and a Bluetooth HRM) every time I used the Trainerroad app on my desktop, it seems to stop the issue happening, I’ve had no issues since.

I hope this helps others, otherwise I may be one of the lucky ones that’s found something that works for me but doesn’t solve the issue ongoing.