Wattbike Atom - latest firmware update

So I think I made a mistake and updated my Atom with 1.02 firmware. It has become almost unusable, with the rpm / power fluctuating wildly. In erg mode, that means all of a sudden the power needed shoots up or the resistance goes.

Anyone else seen this too ? I have put in a report to Wattbike, with supporting files showing before and after smoothness.

Also, How about issues with Bluetooth on the Atom ? can anyone get the Watttbike Hub app to consistently connect : or even connect at all !!??

1 Like

Hi Malcolm, I have the same experience with the power fluctuations and it is vey irritating. Have you got any feedback from Wattbike?
//Mattias

Hi Mattias. So, the suggestion was to use the Beta firmware ( chosen from the Hub app on the phone / Tablet etc ). In order to do that, I had to reboot the phone and make sure nothing else was running, switch on the Atom, and choose. Nothing. Did it all again, and it loaded the firmware. Did a session, and it actually feels better than before. No notches, glitches, wobbliness. They have all the session details etc, but on first look, I think the beta firmware fixed all of the problems, including the tedious slowness of the bluetooth connections.It connects really quickly now, and doesn’t seem to be put off by other devices around it.

Still testing, but first impressions are good

Try the Beta option :slight_smile:
Malc

1 Like

Super!

Many thanks Malcolm!!!

Have a great weekend!

Cheers,

Mattias

Skickat från min iPhone

Wondering what power smoothing you have set in TR app? I’ve had an atom for a couple of weeks and the first ride was absolutely awful. But I had power smoothing on 7seconds. Turned it to 0 and power control has been much much more stable and predictable. None of the power lurches of the first ride…

Hi,

I have a 3s power smoothing and it works ok but not perfekt. I will also try 0s. Many thanks for your advise👍

Cheers

Mattias

Skickat från min iPhone

I currently have it set to 5 secs. Will try 0 when I get a chance.

Did changing it to zero make it better?

Not really. It was even worse ! It’s now set to 7 seconds : smoother but it interferes with the shorter power intervals.

I’ve got that problem , I didn’t know how to put it into words though to ask someone :joy:
I’ve only used the atom a couple times Since had it the last 3/4 weeks and only rode on wattbike app quick ride not TrainerRoad
Started winter training plan yesterday on TrainerRoad and I done ramp test and it was fine , today done 30min session called taku and it was all over the show .
What can I do to sort it out or have you heard anything ? I thought it could be something to do with the blue tooth connection maybe ?
I’ve uploaded a screen shot to see how un smooth it was. Cheers

Spen

My power smoothing is set to 2 secs. It’s the same setup on the app as it was when I used my tacx flux

Hi Spen. Since I loaded the new firmware, things have settled. I also have a different phone that uses Ant+ ( rather than relying on Bluetooth ) but it is still less than perfect with the connection.

Have you updated the firmware ? https://support.wattbike.com/hc/en-gb/articles/360001178229-How-do-I-update-the-firmware-on-the-Atom- has the information. If you’ve not, before you try to update, I’d reboot the phone so that there are minimum number of apps active, and make sure the Atom is the only thing you connect.

If you are relying on Bluetooth, then yes, I don’t think it’s that stable, especially with other devices running. Even with Ant+ and TR, I have to load the workout before switching on the Atom. If I don’t, the connection is lost as soon as I start a workout. Just a procedure thing, but you really shouldn’t have to do it in a precise order.

I have had some instability since the update too. To fix that, I POR the Atom, wait until it’s done it’s whirring, and then start the workout again. Tedious, and shouldn’t happen, but at least most of the time it’s OK now.

I actually spoke to Wattbike at a recent show. Didn’t get much of a warm feeling, but I made sure they knew.

As to variability of power, yes it looks more variable than it should. Do you see large changes in either power or cadence happening in a second or two ? If so, definitely enable use of Beta code from the Wattbike app.

Have fun :slight_smile:
Malc

Hi mate thanks for the advice but I think I’ll have to show a friend the reply as I am not too good with technical side of things .
Basically I done a warm up on the wattbike app, perfect . Did ramp test on trainer road app, didn’t notice anything.
The next day I did the first ride of the plan which was taku, if your not familiar with that it’s a 30min steady ride… the power kept firing up and my cadence would drop to 50 rpm Even though I was riding steadily , It was so frustrating !
I’ve got a screen shot of the ride to show how unsteady my power was


Last night I didn’t want to take the chance so I jumped back on my tacx flux . Absolutely no problem atall
I use an iPad for the workouts , do you think I should try using my Mac book aswel to see if that helps?
Thanks .
Spen

I always get variation when compared with the perfectly flat lines of some trainers, and tbh, that is probably more realistic than having perfect power curves. However, when the variation is too much, it is definitely a problem : and this is generally when you see swings of 10% or even 20% of your current power output / cadence. This is the point at which the POR is good.

I’m not sure what differences you will see using a Mac / iPad, I use Android or a Wahoo to drive our Atom. There may be some difference in the implementation across platform, but I thought Apple didn’t suffer from that.

Have fun trying.
Malc

Hi mate , I changed it to betaware and it’s perfect now . Like you say it’s not as perfect as my Tacx flux turbo trainer but it doesn’t surge no more .
I also made sure I wasn’t logged in to it on any other devices to see if that helped

1 Like

I had the wildly fluctuating power in ERG mode a couple of times. I’m using an iPad mini with the TR app and I think it may have been a connection issue.

I found closing the app (fully) and then switching the power off on the ATOM for. 30 seconds then restarting the ATOM before opening the App did the trick :+1:

2 Likes

I was having problems with the cadence flying up and down ( my third ride on my new atom) it would shoot to 120 then back to 50 when I was at around 95. I checked all my settings and my power match was on “manual” so I disabled it and it seems to have sorted the problem. I hope this helps

1 Like

Turning on the Atom “before” firing up the TR app is a MUST for me with TR on an iPhone X. Repeatably consistent crappy connection if I have the TR app on before I turn on the Atom… :man_shrugging:t3: