Wahoo Summit feature

Just curious what people are thinking of the new Wahoo Summit feature?
Haven’t seen much on YouTube about it other than @GPLama youtube channel.


1 Like

Based on the views, it’s more popular than what Hammerhead have just rolled out. :exploding_head:

I’m keen to see what the 'hoo have for us in the future.


I am not yet riding on the road yet here in Canada but at first glance it seems a little limited but a move in the right direction. I would like to see remaining distance to climb as a field on the climb page and not just the cue sheet.

1 Like

Very interested to see Shane @GPLama referring to a forthcoming update to Wahoo’s Summit Segment climbing feature during his review of Garmin’s 540/840!

Watch from 11:50 onwards…

Sounds like it might be a decent implementation.


It’s pretty solid. Expect it to be on the ROAM2 and BOLT2 as they are the only units with elevation data in their maps.


Excellent. Looking forward to the release (and the review!).

Awesome! Any idea on an approximate timeline when we can expect this feature to drop? Or can’t say due to a presumed embargo?

FWIW in reply to someone asking a similar question in the comments on that Youtube vid I linked to, Shane wrote:

" The Wahoo climbing feature is close, really close. I’d take an educated guess it’ll be within the next 4-5 weeks. "


Today is May 2, which I believe is when Summit Free Ride was supposed to release.

Checked the companion app and I believe this is it:

Can you confirm @GPLama @dcrainmaker ??

Based on Wahoo’s details on the feature, that is the version introducing it.

Only bad news is that it is only available for the v2 versions of their bike computers.

Release notes are also published every time there is a release, so you can always look there to see what’s up.

Has anyone else had a problem with the Summit Segments after applying the update? I did a route today with lots of climbs. Each time, before the climb, I’d get the usual notification that it was coming up, but the Summit feature didn’t pop up like it did. I haven’t even tried for this in free ride. It was working just two days ago, before the update. The Summit Segment option is active, so it’s not that.

I’ve sent Wahoo a message, but I don’t know how long it will take to here back, so I thought I’d check with other users here as well.

Tried this yesterday on a gravel ride and it worked perfectly. Big fan of this feature!


Used it the last few rides and like it. The only issue i have is it stops hills at grade separated intersections, like if you have a hill that has an overpass, the hill will get split into two. Otherwise it works fine. The estimated time to top appears to be based on current avg speed, which is very inaccurate if you have varying grade

@buirechain i had this same problem yesterday on a ride, my first after updating to the latest firmware. Probably some bug introduced as it was working for me prior.

Which device are you using? I’m using a ROAM v1, so I won’t get the feature on free rides of course, but it seemingly isn’t working on preloaded routes either. I’ll enter a support ticket as well, but if you hear anything from Wahoo, feel free to share findings!

I have a Roam V2. The odd thing is that I’ve since gotten climbs on free rides, but not on the one route I did since the update.

Wahoo said they were looking into it. It sounds like I’m not the only one who reported this, so they’ve passed it onto the tech team and it will hopefully be fixed soon in an update to the Roam and/or app. Customer service said I would automatically hear back once they had a fix, though there’s no estimate of how long it may be.

1 Like

Sounds good. I did log a ticket this morning as well. Hopefully it’s resolved soon. Maybe it is something as simple as they turned off the route implementation when they turned on the free ride version on 5/2. Either way, It was a very nice to have feature that seemed to quickly disappear!

@buirechain, Wahoo did respond back to me as well and I pretty much got the same info back from them. When they responded back they also asked that I provide them my .fit file as well as the route file for the ride in question, which I did… HOWEVER…

I went for another ride today and used the same preloaded route that I used on Sunday. Oddly enough, when I rode the route today, the live summit segment page ACTUALLY RAN as expected. There were TWO things different with today’s ride vs Sunday’s ride that I’ve passed along to them. Not sure if they have any bearing on the issue whatsoever, but thought I’d also pass it along here as well on the off chance others are encountering the issue and wish to experiment…

  1. When I rode this route on Sunday, at one point during the ride, my ROAM thought I was off course (i was NOT) and the “re-routing” message popped up on the screen. Today this did NOT happen.

  2. I rode the route today as part of a scheduled workout, so after loading the route up, I switched the display over to the planned workout page and loaded up and ran the workout. It was this page that was open when I got to the climb. On Sunday’s ride, the standard route page was open.

Note, that I have checked my ROAM and I am still running the same current firmware version that I was running on Sunday, so nothing changed there.