Wahoo KICKR problem

I have a Wahoo KICKR that I bought in 2014 and have been using with Trainerroad since 2015. It has been great, but suddenly the resistance is much too high. It seems like it is about 40-50% higher than it should be (based on how much I have to reduce intensity of the TR workout to keep HR in expected range for the workout). I’ve contacted Wahoo but not heard back yet. The other thing I’ve noticed is the
power baseline in ERG mode is more irregular (sawtooth pattern) than usual. I tried rebooting the KICKR and did the spindown in TR. I can’t complain too much since it has worked great for 10 years, but would rather not buy a new trainer if I can avoid it. Any suggestions on where to go from here?
Thanks,
HN

It might be that another device is also trying to control the trainer. Examples include running zwift and TR at the same time, or running your cycling computer in trainer control mode.

Thank you for replying! I will check that, but I think TR is the only app accessing the trainer.
HN

Hey @hhnease :slight_smile:

It may be worth trying your KICKR on a different training app to see if you get the same behavior. This will help us narrow down the issue to see if it’s app-related or device-related.

Additional troubleshooting steps you can try:

  • Software Update- make sure your Windows desktop is running on the latest software.

  • Storage- make sure you have enough storage on your Windows. At least 2GB so the app is able to run smoothly.

  • Firmware Update- let’s make sure your KICKR is running on the latest firmware update. You can check this on the Wahoo app. An out-of-date firmware can cause some odd behavior.

Lastly, we can always try clearing the TR app data to make sure we get rid of any corrupted data that may be causing your issues:

Uninstall TrainerRoad

  1. In Windows Search in the bottom left, search for “Add or Remove Programs”
  2. In the program list, search for TrainerRoad and delete anything related

Clear App Data

Clearing Local App Data

  1. Use the Windows Search bar in the lower-left and copy and paste %localappdata% into the search bar.
  2. This will open the File Explorer.
  3. Scroll down until you find a folder named TrainerRoadData.
  4. Right-click that folder and select “delete.

Clearing Roaming Data

  1. Open the Windows Explorer again, and insert %appdata% into the search bar.
  2. Scroll down until you find a folder named TrainerRoad. Right-click that folder and select “delete”.
  3. Empty the Recycle Bin

A new folder will be generated automatically the next time you open up the TrainerRoad app, and the software will sync anything that was stored on the server.

Restart Computer

Go ahead and power off your computer entirely and turn it back on

Download TrainerRoad

  1. Go to trainerroad.com/download and re-download the installer.
  • We’re going to run it in a certain way, so don’t start it yet!
  1. Go to your Downloads folder and find the installer. Right-click on it and select “Run as administrator”. Let the installer finish up.
  • The installer might automatically open TrainerRoad. Go ahead and close this window for now.
  1. Use Windows Search to look for TrainerRoad. Once you find it, right-click on it and run it as an administrator.
  2. Now, try logging on as usual.

Let me know how it goes !

Thank you! I checked these things and also Wahoo did respond and had great step-by-step troubleshooting process (link below). It turns out that the optical sensor was dirty – cleaned it as per their instructions and it’s working perfectly. I do appreciate the great customer support from both TR and Wahoo!
H Nease
Troubleshooting wahoo kickr:
https://wahoofitness.yonyx.com/y/conversation/?id=a817d260-413f-11ea-94a4-4201c0a80135&did=f5d47b90-0ed9-11ef-93f3-4201c0a80111&lang=en

1 Like

Good to know!!! Thank you for sharing the steps :slight_smile:

Thank you for the reply. It turned out to be a dirty optical sensor, and after cleaning the sensor, it is working fine.
HN

2 Likes