Wahoo Kickr Core Loose Connectivity


My Wahoo Kickr Core easily loses the connection, during a session the watt´s reading suddenly drops for a few seconds and then returns to normal, another situation that happens, when there is a peak power for example of 5 seconds, usually when time is running out is that it reaches the desired power, and at other times it ends up being halfway, and at other times it ends up barely or not at all.
The Wahoo is 2 steps away from the computer that has a pen ant + from Garmin latest version, I already bought an cable extension and already put the pen against the Wahoo and the problem still happens.
I have the last firmware off Wahoo

I’ve experienced something like that for some time and then it just went way. Something was interfering or not properly updated and that happened in 2 digmfferent oeriods two in the 8 months I’ve got the CORE. If it reconnects quickly its annoying but not a big deal but on my second time the core could not recconect by himself at all. I had to disconnect and connect it again manually and that it’s very difficult to do when in the middle of a hard training and as I said it happened for some time on both periods around a week or two with those kind of problems not in all trainings but is most of them some times just a couple of times others more than a couple of times.

The second time this happened after a few times I’ve contacted TR support but there’s nothing in my log that justifies this. It passed again I hope for a long time.

The problem is that I try Trainer Road about 2 weeks and 3 times a week and I thing that have problems in all, but with Ergovideo in 1 year I don´t have problems, or in Zwift that I use the free 25 kms every month.

Never had issues so far (1 month swift, 3 weeks TR). Kickr core connected with ANT+ to A Samsung s8 on the handlebars

You’re using a smartphone not the PC app maybe there’s some difference in the apps but I think 3 weeks is still short. In 8 months of TR it happened in two periods some times in each period but not all days and then it stopped.

Contact support maybe they can see something in your logs.

I had the same thing happen today. I was running TR on my Mac with Favero Assioma Duo pedals connected via BLE and KICKR Core set to powermatch via ANT+. When the target power of the workout dropped form 246 to 115 for a quick 30s break, the KICKR kept the resistance and would not change. I eventually disconnected it from TR, reconnected but then it would not give any resistance. I had to completely unplug the KICKR and then plug it back in.

In your case the resistance is controlled by the readings assioma gives to TR. That’s interesting because I’m suspecting my problem is that the Bluetooth and ant+ sensor on the trainer sends a week and with some ups and downs signal to the ant+ USB inserted by an extension cable in my pc. Your comes from the assiomas so it’s a bit different.

In my case, the issue is still related to the KICKR not responding. I essentially stopped pedaling (you can see the data on my Garmin which was linked to only Assioma) but the KICKR got “stuck” at a power level and would not change.

When the connection between the trainer and TR drops in my case TR maintains the same power until I manually recconect the trainer. This is not a big deal when I’m in low watts but when in a Vo2 max and the connection brakes I’ve got to struggle to reconnect manually while keeping the same power when it should have decreased automatically. This is really painful.

The second I recconect TR puts the trainer on the correct watts target.

1 Like

I’ve had what I think is the same or similar issue with my Kickr Core. It won’t register large wattage changes, e.g. going from a recovery to threshold interval, sprints, etc. I contacted support, and they had me delete all config files (~/Library) and reinstall. I did a 30x30 sprint workout this week as well as racestart SS intervals and I didn’t have any drops, so far so good!

1 Like

My last to workouts did not turn out well. I run Kickr Core and assiomas.
Only Assioma connected to swift ( PC), and no controllable trainer.
Trainerroad runs on android phone and running kickr core and assiomas in erg and powermatch. This setup has worked flawlessly since November.
After sweet spot intervals the kickr won’t release down the wattage and just holds it. The only solution I have found is to save and exit the workout, kill trainerroad app in android and turn power off and on on trainer. Restart and resume workout in trainerroad. After next interval the same happens again.

Any ideas as to what is happening and what to do?

I’ve been recently experiencing the same issues that you guys have mentioned.

Samsung galaxy S10 (using power match in TR app)
Assioma Duo (ant+)
Kickr Core (BLE)
Garmn HRM (ant+)

I have to kill the TR app and reopen to get the trainer connected again. What’s weird is that the TR app shows that my Kickr Core is connected with no power reading (Assioma shows power, and trainer holds you on the power that it had before it lost connection), but the wahoo trainer has the blue light blinking (which means that it has no connection). Not sure what to do. Any solutions?

Try using only ant+ on the s10… On the s8 I had no issues with BT and ant + both on and connected, but when I upgraded to the s10 I had turn off BT to complete a workout without freezes… now I simply make sure BT is off.
(Support confirmed more people with the s10 having issues)

1 Like

nvalphen, I tried connecting via ANT+ today (turned off BT on my S10) and that appeared to have worked. Let me try a few more sessions and see if this stays true. Thanks again.


I’ve also been having connectivity issues with a Kickr Core and Bluetooth with a MacBook Pro.

My MacBook pairs to every other Bluetooth device and the Kickr pairs via Bluetooth to every other device I’ve tried (Android phone, tablet, iPhone, and iPad).

I’ve tried deleting all cached profiles/data from the MacBook and reinstalling TrainerRoad, but no improvement yet.