Wahoo Climb not working with current MacOS Monterey - anyone else seeing this?

Hi - I have recently upgraded my MacOS to Monterey and since then have noticed that the Climb function isn’t working on my setup anymore. I’ve tried to work with support on this but no joy as yet.

I’ve repaired the devices, updated firmware, reinstalled the app, etc. but no joy. The same setup works fine on my Android so it’s something to do with the Mac version and/or Monterey.

I’d love it if someone could confirm this behavior either way so I know what to try next.


Sure you’re on the right forum? :rofl:

I’ve had the same issue and have gotten no real help from TR on this. They told me to do what you did. Didn’t help. They then said to try and go back on previous Gen firmware, which doesn’t seem right.
No update has fixed it yet.

1 Like

What? You know the climb is supposed to work on TR workouts right?

This is news to me and now feel like an idiot/ass. Learn something everyday!

1 Like

So I finally got to the bottom of this with support - seems the issue originated with support for the Fitness Machine Service Bluetooth protocol and affected all desktop apps. They are working on a fix for this although no timescale was given. For now, I’m using the Android app which is not affected by this issue.

1 Like