Two EW-WU111's, one Garmin Edge 530

Hey all! I have an interesting scenario here. I have Di2 on both my road bike and gravel bike. I have had an EW-WU111 installed on my road bike for some time - all settings left in default mode. This past weekend, I added another EW-WU111 to my gravel bike. At this point, I made profiles in the E-Tube app, named one “Road Bike”, the other “Gravel Bike” and gave them both unique passwords. Battery on the road bike was at 90% on Saturday, but I went for a gravel ride on the grav grav bike instead. Connected the new EW-WU111 to my Garmin Edge 530 and I was off to the races.

This morning when I pulled down my road bike for dawn patrol, my battery was totally drained - down to zero percent. The battery is new this year and I have never had even close to an issue. This seems connected to multiple EW-WU111 units in the garage.

Anyone else ever chase this ghost?

Did you use the mobile E-Tube app or the PC version?

Both, actually! But I typically really only use the PC version. I find the mobile app to be crashy. It bricked my setup once, so it made me a little gun shy going forward.

How did you connect the units to Edge? Bluetooth or Ant?

Sometimes I’ll have devices that get stuck paired via bluetooth, so I try and always connect them to headunits via ANT to avoid this. (I’ve had it with power meters as well)

I always just add them as sensors from the Garmin menu, so I have to assume that this is Ant, no?

Known issue with the E-Tube Windows app… if you don’t click the DISCONNECT button once you’re done it’ll remain in connected/pc/whatever state and drain the battery in a few hours. Not sure they’ve fixed it in 4.0.4… or if it’s something that can be fixed? Speaking from experience of finding the bike DOA the next day too.

2 Likes

The headunit should tell you what protocol it’s connecting over in the device info IIRC

It was even worse than that, at least in 4.0.2. You could hit the “Disconnect” button and think that it had disconnected but due to a bug it didn’t really disconnect and leave the system in its normal state. Happened to me too.

I experimented with it some and emailed Terry at Bettershifting.com. He had run into the same issue and sent me the response below. Not sure if they fixed it in 4.0.4.

If it happens to you, you can tell by the lack of the battery icon shown in the upper left corner of the app window next to the “Disconnect” button when you connect. The trick then is to disconnect, then reconnect and the battery icon should show up. Then you can disconnect and all should be well. Or you can just use the phone app or PC v3.4.5

yeah… I’ve sort of had the same issue. I think I know how to ‘detect’ it, but not what causes it.

One day the past few weeks my indoor bike was fully drained, no charge at all. I suspect this is caused by e-tube not disconnecting properly and draining the battery that way.

The next time this happened I made a video of this and sent it to Shimano: Unlisted E-Tube Project bug(?) for BHI - YouTube

When I connect the bike for the first time in the video, you see the ‘battery icon’ is not displayed next to the ‘disconnect’ button.

I think that this is a sign that something went wrong.

In this state I cannot adjust the derailleur indexing, but perhaps more importantly:

If I disconnect the bike (using the button) when it is in this state, then the bike stays connected. You can test this by pressing any of the the (rear) shift buttons. The rear derailleur should move. If it doesn’t respond then the bike thinks it is still connected.

The fix for that is, in my case, to connect E-Tube 4 again. This time it does show the battery icon next to the diseconnect button.

When I then disconnect the app everything works as expected.

So… I’m wondering if you get the same - sometimes the battery icon and sometimes not… and a non-responsive bike if you disconnect when the battery icon isn’t showing.

E-Tube 3.4.5 is still available for download on the official site, but I’ll probably mirror that too, just to be sure :wink:

1 Like

Very, very interesting. That certainly resonates.

But what still confuses me is that I have ridden the road bike at least a dozen times since it was last connected to the windows app, mobile app or the charger. It was 90% on Friday, 0% today and i had not touched the bike.

The gravel bike has had the EW-WU111 in it for several weeks as well, but I only connected it to my Garmin on Saturday.

I wonder if that set off a cascade. Looks like I will need to set up a test and see what happens!

IDK. That sounds like a different issue and I have no idea what would cause it. I only have one Di2 bike so can’t be of any help there.

Maybe when you were setting up the gravel bike you accidentally connected to the road bike. Or maybe the computer did when you opened the program?

There’s known bugs in the setup programs, so maybe another one different then mentioned above.

Perhaps it’s completely unrelated to the wireless. Could the shifter button have been accidentally leaning against something?

At this point it’s only happened once and may not happen again. I would be cautious regarding connection to the PC and your bikes. If you see the issue repeat then you will have more clues.

I had a similar issue - really frustrating because I wondered whether the battery was due a charge, so checked (via the Garmin headunit, not connecting to the PC interface) and it reported 50%. Went to go for a ride the next day and it was completely flat.

I’ve only got one bike with EW-WU111. The bike was in a stand, so the switches were not leaning on anything.

My best guess was that I had my Garmin headunit on charge, so it was switched on (not sure why they switch themselves on when charging…) and may have connected to the Di2 and drained it.

Otherwise some Di2 bug that will be difficult to recreate and track down as it seems so infrequent.

Weird. I have an EW-WU111 on my road bike and CX bike, both connected to my Garmin computer. Haven’t ridden the CX bike since November so I got curious and wanted to check mine. Still has about 60% battery and shifting fine. Don’t remember the last time I charged it but it definitely not since the CX season ended.

I thought of this too since I’ve done it before. Other than that, I’m not sure what caused the drain. But I’ve never had problems with 2 wireless units connected to the same computer.

I would say that this has been the best experience that I have had on a forum ever, as so many folks have replied with such good information so quickly, but the honest truth is that it is the best because I have now interacted with someone who’s screen name is - CAPTAIN THUNDERPANTS! That is as hors categorie as it gets, I say.