TrainerRoad Windows App Disappeared

My TrainerRoad App disappeared from my Windows 10 laptop. There two days ago and today when I tried to open I have an odd icon and no app.

Have you tried reinstalling?

yes just did and all appears well. launched the app and it pulled up my account and all paired equipment. Odd but all good now.

1 Like

I find it disappears from the task bar with each update. Even it if it is a small update, it removes itself from being pinned there for me. Wonder if it is doing something similar with shortcuts?

If you are regularly experiencing these issues, would you both mind reaching out to our Support Team at The Support Team has some additional access that will allow them to look and see if we can minimize this quirky behavior you’re seeing, and if not, they can properly catalog and report the bug to be resolved :slight_smile:

Thanks guys!

1 Like

Will do, Bryce. I notice this with other apps on the taskbar as well, so I had assumed it is just normal behavior with Windows 10.

1 Like

Thinking back I remember I had an update notice at the top of the App when I finished my last workout. Rather than relaunching app right then I shut down my PC. Two days later when I tried to launch the app it would not launch (didn’t appear in app list) and I had to download and install again. Fortunately though it remembered me and all paired devices so minor inconvenience.

1 Like

Just had exactly the same thing happen to me. I was having issues with my HRM so decided to restart my computer. I saw the update notice, but just assumed it would update after the restart. However, upon restarting the computer the TR shortcut on my desktop no longer linked to any software, and when I searched for, and clicked on the app from the search bar, Windows couldn’t locate the software. Maybe one to look at @Bryce ?

Thanks for bringing this up, could you report this to our Support Team at so that we can look into this?


Jyst sent them the link to this forum post.

This happens to me too. Just did it again today on Windows 8…

Last time I used it there was an update pending.

Hey! So sorry to hear you’re experiencing this issue!

Our support team is looking into what is causing this issue, do you mind sending them a request so they can create a bug report accordingly? It definitely helps to include information such as current TrainerRoad version and operating system version (we see it’s Windows 8 but support isn’t always privy to these Forum threads!), and they’ll get you sorted!

You can contact them at Thanks in advance and apologies for the trouble!

1 Like