TrainerRoad Time Warp?

TL;DR - TrainerRoad workout running at 5/8 of real time.

I had Phoenix on the schedule today, and dutifully got after it this evening. As always I was running TR on my PC, connected to my P1s with PowerMatch enabled with my Kickr Snap. I also record rides on my Garmin to have the data is many different places (more data is better right?)

I knew Phoenix is just under 100 TSS for a 90’ workout, and looked at my watch ~30’ in and saw that I was already at 50 TSS for the workout, and thought that was odd. I kept going and noticed that the math kept not working out for a steady state workout. I checked the Garmin and sure enough it was at 56’ minutes when TR had me just past 30’. I was confused. I checked my phone and looked at the time I sent a text to a friend before I started pedaling, and sure enough it was 56’ ago.

At this point I thought I was in a black hole. I was confused. Both clocks were ticking away, but they were diverging. I broke out the stopwatch and realized for every 15 seconds that TR ticked off, 24 seconds passed in real life. I was even more confused. I still wasn’t convinced, so checked how long the movie I started had been playing, and that was 56’ too. Now I was convinced.

Any one else ever had this happen?

On a positive note it explains why the first “30 minutes” of the workout felt like it took so long, on a negative side this was also the start of dialing in my nutrition timing, and it certainly didn’t help that!

Links below show what I mean. TR ride shows 56’ total, while Garmin shows the whole 90’. If I was feeling fancy I would overlay them and make a pretty picture, but dinner sounds better.

TrainerRoad Ride Link

Garmin Connect Ride Link

Thanks so much for reporting this, I have not seen this before.

I have a few questions to try to help me understand this issue a little better:

  • Does your computer meet the minimum system requirements?
    – 2.33GHz or faster x86-compatible processor, or Intel Atom™ 1.6GHz or faster processor for netbook class devices.
    – Microsoft® Windows® Server 2008, Windows 7, Windows 8 or Windows 10. (Be aware: if you are on a Beta version of the Windows operating system, the TrainerRoad app may not function properly)
    – 512MB of RAM (1GB recommended).
  • Did you have any programs in the background that may have been robbing TrainerRoad of the processing power it needs?
  • Have you successfully used this PC with TrainerRoad in the past?

I have also asked a Support Agent to reach out to you via email so that we can properly investigate this bug, so look out for an email from us :slight_smile: . All of our agents are off for the day, but you should hear from us tomorrow morning.

So sorry for the inconvenience, we will do our best to make sure this doesn’t happen again :+1:

Thanks for the reply Bryce (on a Sunday even!). Computer definitely meets the minimum specs, and has been used to run TR for about six months now. I ran the program the same way as always; booted up the computer, TR starts on boot, and away I went. No other programs running, and nothing different than normal. I did pause briefly ~7’ in, but I’ve done that plenty.

Thanks again for the help, I’ll look for an email tomorrow! The fact that I can post this in a forum Sunday night and get a response is one of the reasons I love TR. Keep doing what you guys are doing!


Of course, we’re always happy to help :slight_smile:

This is not a bug!

This is a little known hidden HTFU feature for the TR hardcore :sweat_smile: The question is how did you inadvertently activate it :thinking:


Ya know I thought about this in the middle of the workout… “What if I just didn’t realize it and did the whole 2.5ish hours at tempo”. Then I thought that I was VERRYYY happy this was during a tempo workout and not VO2. 3’ intervals that are closer to 5’ would be no fun.

@Bryce, never heard from support, but I have ridden all this week without any issues, so thinking it was a weird one-off thing! Thanks again.

I think another appropriate question would be “do you live near any type of gravitational singularity”

I tried to form one on my last Ramp Test, but turns out I am a mere mortal :man_shrugging:

Ah shoot, I’m really sorry Support dropped the ball this time around but I’m glad to hear that the problem seems to be an isolated incident! If you ever experience this issue again, please report it to us at so that we can properly investigate the issue :slight_smile:

Few physicists realize it, but exercise also affects time-space. I was doing Town Hill (2,75 hours) a year ago and time stood still at 2,5 hours. The only way I could make the clock resume was by bailing the workout.

1 Like