TrainerRoad stopped receiving/recording power

I have been using TrainerRoad for the last couple of weeks, having previously dropped it about 18 months ago. I was 45 minutes into a 1.5 hour workout yesterday and everything was fine.

Then, at a transition into a segment with a higher power (85w to 176w), the recorded power from my Kickr stayed flat i.e. didn’t budge from 85w. The actually power I was delivering - as dictated by the workout - continued without any issues. So the workout was fine in the sense that I continued to have the Kickr driven by TrainerRoad exactly as planned, but the recorded power just remained at 85w for the remainder of the workout.

I am running a Kickr V1 on Windows 10, with all updates (OS and apps) installed, connected via Bluetooth. I have never had an issue with this setup, including hundreds of hours on Zwift and, until yesterday, no problems with TrainerRoad.

I tried a number of things mid-workout, including switching my device from Erg to Resistance, etc but no matter what I tried the recorder power remained at 85w.

Tellingly, I started Zwift during the workout (not to drive the Kickr, of course, but merely to record what my Kickr was doing). It reported the exact power that TrainerRoad was wanting from the trainer. So, for example, if the workout required 176w, Zwift was reporting exactly that (and changed as the workout profile changed, as I continued the workout) - but TrainerRoad recorded 85w and never changed again.

Anyone have any idea what is happening here?

Send an email to support. Also, restart your kicker and make sure the firmware is updated.

Good luck.

1 Like

Thanks. Yes, I will follow up with support but was curious if others had seen anything similar.

My guess is that this is some weird issue with TrainerRoad itself, since Zwift continued to report exactly what I was riding, as driven by the workout (so, the Kickr seemed to be doing what was asked of it). I have the latest firmware installed.

Thanks again.

You REALLY dont want to have ANY other apps or kit open that connect to your Kickr at the same time as TR.

I had a similar thing recently simply because my Wahoo was running and had decided to latch onto the Kickr in the background. I am willing to bet its Zwift that is the issue - the gen 1 Kickr seems very susceptible to interference and when it gets it then all sorts of weird things happen.

Thank you.

Drat - that’s a shame. I have some mileage-based goals I have been targeting all year and have been on Zwift for a number of years. I am aware of the compromises/debate over this, but running Zwift and TrainerRoad together (with Zwift just recording miles) has been the reason I signed up for TrainerRoad again. I greatly prefer TrainerRoad for the workout / plans aspect, but do want to record milage with Zwift, even with the qualifiers about accuracy/realism.

By the way, can you clarify by what you mean by “latching on”, in this context? Do you mean that Zwift inappropriately starts controlling the power? If so, I did check that yesterday and it was in “passive” mode throughout and the power profile I was following (both in terms of what Zwift reported and what my legs told me!) changed exactly in sync with the TrainerRoad workout I was riding. So I am confident that Zwift wasn’t controlling the Kickr.

I am sure you are right about Kickr V1 in comparison with later versions. Funnily enough I have been looking for Black Friday deals on the latest Kickr, though not confident :). But aside from this TrainerRoad issue, I haven’t had an issues with my setup, over many years of use.

To be honest, when I set this “dual mode” up, I almost expected some potential issues with the controlling aspect, but had (apparently incorrectly) assumed that reading power from the Kickr would have been pretty consistent. It had been over maybe 15+ hours of dual use…until yesterday :frowning:

Thanks again.

No idea what is actually happening but Wahoo support told me that if there is more than 1 app/device being used then they can simply cause interference with each other and the net result is issues. I had major resistance spikes continually (every 30-40 secs etc) and mine wouldnt spindown via TR. If I switched off the Wahoo it all went back to perfect and not a single issue. They’re initial advice was to make sure there were no other apps running on the phone or laptop etc as it would do the same thing.

I have a Kickr - Gen 1 that has been doing that as well. I don’t think its latching on to anything else but did the same thing- the power reading freezes and but the resistance is still there (i can even control the resistance on my phone using the TR app). Last i checked a few months ago my firmwear was up to date but looking forward to what others find.
I have a feeling its the dual latching thing. I’ve tried to just compare power readings with my wahoo head unit recording and it went all wonky.
BTW Markwill my mileage gets recorded on strava when i do TR workouts. However i do understand and think that TR needs to rethink the mileage thing. I know the debate has been beaten over and over by the TR guys that “mileage doesn’t matter” but having mileage goals is a real thing and matters to a lot of riders.

Thank you. Having completed quite a few workouts with both TrainerRoad and Zwift, without issues, it would be a shame to discover that this is going to be a problem. We will see what happens with future rides.

I have a friend, Lenny, who logs his miles to Strava from TrainerRoad. They have become a bit of a joke (we call them “LennyMiles”) since they are so amplified. He regularly logs hour long workouts of 30 miles :slight_smile: He’s certainly fitter than me but not by THAT much :slight_smile:

So, yes, for unscientific / approximated mileage goals like I enjoy (and, I suspect, many others do too) the Zwift thing is a bit of a savior.

To be perfectly honest, the ability to run Zwift alongside TrainerRoad, for this reason, was precisely why I reinstated my TrainerRoad account. I don’t want to be logging weird “MarkMiles”, polluting my records :slight_smile:

1 Like

A quick follow up to this…

I happened to purchase a Kickr 5 yesterday, finally replacing my Gen 1. Unfortunately, the issue I reported here happened again, which is a shame. I had hoped that there would be something about the Kickr 5 that might help with this :slight_smile:

I should add that the Gen 1 did this just once (when reported here) over maybe 30 or so rides since I resubscribed to TrainerRoad. The Kickr 5 had this happen with my only ride (so far).

What still remains a bit confusing to me is that the use of TrainerRoad with Zwift. while not officially supported, seems like it’s pretty common (others have mentioned it quite consistently in this forum, videos on YouTube about how to set it up and so on). I can’t imagine these folks would just live with this issue, so I am not yet clear on why this is happening.

Anyway, the Kickr 5 thing was a bit of a disappointment.