TrainerRoad outside workout causing Garmin Edge 830 freeze

Hi folks,

I am a new TR user and I have raised this in an email to Support but I’m wondering if anyone else has experienced this as it’s so frustrating and has delayed my planned workout today. I’m only 7 days into my membership and have otherwise been so impressed but this is so fundamental it has really disappointed me with TR’s capabilities!

In short, my outside workout has been pushed to my Garmin Edge 830 but when I try to open it, it freezes the whole device. I can’t do anything other than hold down the power button and reboot the device.

I have tried disconnecting/reconnecting TR and Garmin. I have also manually wiped every single historical workout, route and activity from my Garmin (via USB and then from my PC) to ensure it’s not a space issue. I have never had this problem with literally hundreds of workouts pushed from TrainingPeaks to this same Garmin device. And there are no pending firmware updates for my device.

Has this ever happened to anyone else? The workout is called Aiken. It’s just like the .fit file being pushed from TR is corrupt or something.

I’m now giving up and just going to do an outside ride without following the workout on screen. At least it’s just a simple Zone 2 endurance ride. This would be so annoying if it had intervals in it and I wouldn’t have them on screen to follow them.

If anyone has any other suggestions to try please do let me know.


Bumping this because it happens to me occasionally too. However, I have only noticed it with workouts that have a ton of intervals. So, typically these are 30/30 and other VO2 or anaerobic workouts. Still not sure what the problem is but resetting the garmin, manually deleting the workout does not solve the issue. My guess is that the Garmin workout software cannot handle more than certain number of intervals.

50 steps is the limit, however “repeat” is a step.

1 Like

There is a limit of “steps” (intervals). I ran into it planning a WO. However, I don’t remember what the limit was? Maybe in the range of 30-50 steps.

Steps. Not intervals.

This has over 200 intervals, including 198 intervals of 30-seconds each (plus warmup, cooldown, set breaks):

but each set of 33 (66 intervals) which I believe (without loading into is only counted as 3 steps:
step1: repeat 33 times (step2 and step3)
step2: 30sec hard
step3: 30sec easy

so that workout is about 14 steps with warmup, cooldown, intervals, and set breaks. Well within the limit of 50 steps.

Loads and runs on Garmin.

1 Like

TR support fixed this for me. It was an issue with that specific workout and has not happened to me since with any other workouts.

1 Like

Thanks for clarifying. I was unsure which word when I wrote it.

Can you elaborate? Which workout and what did they do?

I’m surprised that a relatively new Garmin device can’t handle more than 50 steps. It’s not like we’re asking it to solve the three body problem. It’s just “show this value for this time interval” and emit some beeps.

I’m not sure it was anything to do with steps in my case. The workout was Aiken and they just said there was a mistake with the outdoor version where they’d incorrectly made it really long. Not sure if that meant some kind of crazy duration (like over 24 hours) or if it was steps but they fixed it and I’ve never had this issue with any other outdoor workout. I usually load one or two outdoor workouts into my Garmin Edge 830 every week and not had a problem since.

1 Like