TR will not let me manually change FTP

I had knee surgery and want to reduce my FTP to put my fav workouts back on the menu. I don’t want to test, I know exactly what I want to do. But the app or website both will not accept my changes. I go to “account” and edit FTP and weight (yes, I have also gained weight), TR prompts me to confirm I want to change these settings, I click OK. But when I go to any workout it still shows my old FTP. Then if I go back to the exact account area where I made the changes, that has also reverted back to the old numbers. I am stubborn and have done this about six times, no joy. What the heck?

Best to reach out to for this issue! I’ve not manually adjusted my FTP in some time, but it worked as expected last time i tried.


Just a guess…maybe a format issue with using comma or point in the weight number…you might try using a rounded number without comma or point (or use the other dividing symbol).

Hey @raylo :slight_smile:

It looks like you’ve received an answer from our Support team already, but I’ll post it here just in case:

After taking a closer look at your account, I noticed your date of birth is set to 01/01/3000. Since this date of birth is invalid, this is the reason your FTP and weight are not updating.

Once you set your date of birth to a valid birth date, it should allow you to manually update your FTP and weight.