TR crashed 3x during my second workout

Hi there
I am new to TR and attempted to do my second workout today. I usually use Zwift so I followed the Zwift Insider instructions for running both concurrently using Ant+.
This worked fine to begin, and worked fine on my first training session. However today at around 20 mins in my laptop screen went black. It didn’t switch off or reboot it was just a black screen and when it righted itself only Zwift was running and TR had crashed.
I re-opened TR and was able to resume the workout, but 10 mins or so later the same thing happened again. Once again I was able to reopen TR and resume my workout. At this point I decided perhaps Zwift was causing some sort of issue so I then closed Zwift and tried running TR stand alone. This worked fine for around 10 mins and then it crashed a third time. Unfortunately when I went back into the software you could see the workout showing an elapsed time of 41 mins but it would not re-open/synch or anything. It was like the workout file had corrupted.
So have I just had bad luck? Anyone any idea how I can:

  1. Get TR to run against Zwift and avoid the crashes
  2. Get my corrupted file to open, not essential but if there is a quick win.
  3. As an aside when I did my first workout Zwift recorded 21 miles and TR 9.7 miles, a massive discrepancy. Now I know Zwift is generous but given my average power output my guestimate for approx miles covered would be around the 17 mark. So I think TR has massively underestimated distance.
    Hoping I can find some answers to this as I love some of the ideas and direction this software is moving with the Adaptive Training and AI I can see it being of massive benefit. Unfortunately atm I cannot see beyond the frustrations and wasted time I had this morning.
    Many thanks in advance for any suggestions you may have.

TR actually doesn’t estimate distance at all - it just takes what the trainer or speed sensor gives it. Zwift calculates a virtual distance based on power and virtual terrain.

Some trainers, such as those from wahoo, can calculate virtual speed based on power but most will just report something that corresponds to wheel revolutions and this will vary depending on what gear you are in.

I cant help with the TR app problems you are having though unfortunately, I find the app to be pretty stable on my 8 year old laptop with windows 10, I can only suggest making sure you have the most up to date ant+ drivers - maybe reach out to support?

Don’t think this is possible…you need to run one on BT and other on ANT+, and then set Zwift to just receive the power readings (disconnect the controllable trainer in the menu).

I run TR on my iPad and use BT and connect to Zwift on a laptop using ANT+…but you can go the opposite direction, too.

I do the same as you, one BLU and one ant+, but i think you can have both via ant+ if you have two ant+ dongles.

Agree that you cant link the trainer as controllable in zwift if its linked in TR though.

Best protocol for issues like this is to reach out to Sorry you’re experiencing that, its definitely not normal and I bet the team has some killer advice to help mitigate those crashes!

It ran fine with two Ant+ dongles on my first workout a couple of days ago.

Thanks, I have raised this as a ticket. I was thinking others may have encountered similar problem and have a solution, hence I thought I would ask on the forum first.

1 Like