Tacx Flux 2 Not Matching TR Power on Erg

Hi Everyone,

I’m having an issue with my Tacx Flux 2, where when I ride on Erg mode, the trainer won’t consistently hold the power it should on the workout. The wattage hovers 5-10 watts below the recommendation, and the only way to boost it up is if I begin to really stamp on the pedals, and bump up my cadence. This will cause it to match the recommended power, however it will only last a few seconds, then go back down below. It’s not that I’m struggling with the workouts - and I’m consistently holding a cadence between 90-100 throughout the ride

Please note I tried calibrating both the trainer on the Tacx Utility app, and on TrainerRoad itself, before the workout. I’m riding in the small ring (36) and in the middle of the cassette.

My previous trainer was a Kickr Snap which I used with TR for 3 seasons - the power consistently stayed on-target within a 1-2 watt margin of error despite my minor changes in cadence.

I just want the wattage be delivered more smoothly and in-line with the target wattage. Is this a hardware issue I need to take up with Garmin, or is there a settings fix I can try myself?


I’m curious if there’s a solution to this, as I have more or less the same issue. However, mine is slightly different: everything up to about 240-250 watts is spot-on, then from 250 to about 280 it usually sits about 10 watts low, and from 290 to 320 it’s giving me 10-15 watts more (fun if you’re doing vo2max intervals! :open_mouth:). And from 350 and upwards it’s nigh on perfect again. I’ve learned to live with it, but if someone could shed some light on this I’m all ears.

  • With any Wahoo trainer, chances are good that you had the “Enable Power Smoothing in ERG” turned on, which is the default from Wahoo. Having that turned on gives super smooth, and quite unrealistic power data. It makes you think your are hitting power perfectly when the truth could be different.

  • Watch the following video to understand the setting. And then come to the place where you accept that power we produce is anything but smooth and perfect. Sweating a few watts one side or the other from a target is not really beneficial.


Totally agree, I can live being a few watts off as long as I know it’s normal and not a hardware problem :laughing: - thanks for your prompt response!

1 Like

If you are intent on hitting a bit higher (or lower) wattage as an average, the “trick” is to bump up/down the Workout Intensity a percent or two. That will nudge the power target a few watts with each step, but still let ERG do the work.


@genepanini I own a flux 2 and had the same issue as yourself.

The advice from @mcneese.chad is spot on, a 2% increase in intensity and letting erg mode do the work whilst keeping your cadence tight is a much better outcome than chasing the right watts which ends with a very fast cadence. This behaviour prematurely fatigued me and you dive down a hole and everything becomes much harder.

Whilst this seasons workouts don’t look as pretty and as compliant as last years from what’s been said I have an unvarnished and accurate image of what is actually happening.

I’m now more confident of good compliance with the coming weekends workouts and as I head into MV2.


I also have the issue if I increase the power by 2% that would the whole interval is increase the drop out is only for a few seconds at a time than pass, it’s annoying. I find it won’t sometimes increase or decrease so I can be in a hard interval and the power drops and I spin out then it returns and I am playing catch up and then during the recovery it still too high.

It’s spoiling the “enjoyment”

Not sure if it linked to the TR app or windows 10 updates