Problem with ERG with Stages power meter and Tacx Vortex Smart

Hi Guys!
I recently started training with TR, after using Zwift for several years in winter. Really enjoying it!
Last week, I also bought a Stages Left only power meter, to have the same “benchmark” when riding inside and outside.
My first ride with the power meter paired, ERG mode went weird, so I disconnected the Stages power meter. Today, I did a new test and paid more attention to what was happening.

Stages and Tacx both connected through Bluetooth, using TR Desktop on a mac.
As you can see in the picture, the rest in between intervals should be at 106w. Every interval though, the trainer went higher in resistance, until +170w. I did not shift gears at any moment, so no confusion possible.
When I disconnected the Stages, everything went well again, and the ERG mode in the trainer took over.
Powermatch was set to “Legacy”, since that was the default setting, so I didn’t change that.
My power meter was calibrated before the workout.

Am I missing something here?

Hey! Any issues with power readings or with ERG or Resistance modes or settings should for sure be sent in to the support team. While it’s likely that other athletes here on the Forum have had similar experiences and may have a fix for you, the support team is able to look at the internal ride log of your workouts and see whats amiss with those resistance commands, so you should definitely check in with them to get the best assistance possible!

You can email them at, or submit a request online. Sorry for the trouble, they’ll be able to sort you out! :v:

Thanks a lot! I will email them right away.

1 Like

Yes!!! Same thing happens to me with iOS, Stages left-side & Tacx Flux with Power Match enabled! I simply have to disconnect the Stages & run only the Tacx for the workout if I want ERG mode. Any solutions would be appreciated!!