Stuck at 'setting up your calendar' after update

There was an update available this morning for the app, Mac OS, which I did and now I am stuck at ‘setting up your calendar’ when opening the app on my laptop. Tried restarting the app, computer and even did a reinstall to no avail. Anyone else with this trouble after the update? Already sent the support team an email.


Same thing for me. I tried uninstalling the Trainer Road app from my Mac and reinstalling, but nothing.

1 Like

Same here for MacOS. Restarted laptop, uninstalled/reinstalled, still stuck 1 hour 30 minutes later.

1 Like

Hey all,

Appreciate the heads up – our developers are working on a fix for this right now and we hope to have this issue solved soon!

Same Here

If anyone else happens to encounter this issue, please reach out to and we can help you install a previous version of the TR app to temporarily bypass this bug.

Alternatively, if you can use the TR app on a mobile device/tablet or a Windows PC, those versions are all working properly at the moment!

Good news! This issue has been fixed. :slight_smile:

  • Restart the app and the issue should resolve itself
  • If restarting doesn’t resolve the issue, grab a fresh install of the TrainerRoad app from the website.

Let me or know if you need a hand with anything else!