Strava sync and re-sync issues

Hi,

One of my workouts was synced with Stava without pushing a picture of a workout. I decided to delete workout on Strava. After 24h I pushed “Re-Sync ride” in Trainer Road mac app, but workout did not synced. I tried to push Strava icon on workout page, but every time it was freezeing with “Processing…”. Disconnect and link again to Strava did not helped. I tryied all these actions many times and with different sequenct - no luck.

I’m not sure why the picture did not synced just after workout was synced first time, as far as I understand issue can be both on Trainer Road or on Strava side. But anyway -did anyone managed to make deleted re-synced?

How long did you wait before deleting? This happens to me often - but usually after 10-15 min the screenshot loads in Strava without me doing anything. No idea why there’s a latency.

3 Likes

If you go into the ride in TR, at the bottom of the screen there is an “Analyze” button. Click it…

That will take you into the details where you’ll see the download file button. Click it to download the file and then go into Strava and upload. You won’t get your picture, but you’ll have the workout in Strava.

Usually picture was uploading immediately, so I just decided to re-sync just after I noticed that, I can’t say how long time passed after the workout but less then 30 mins.

So you noticed that the picture of a workout appears not immediately, that is interesting…

Thanks. Actually that is what I did after a number of not successful attempts.

But the question is in general - why deleting of a workout on Strava and Re-Sync is not uploading workout again?

I had similar issue before and was told by Support Team that I need to wait 24 hours, so this time I waited for 24 hours just in sake of testing if Re-Sync with Strava works, but it didn’t/

1 Like

Hey there,

As @sthall said, sometimes it can take a bit longer for the image of your workout graph to sync over to Strava.

The image will only be synced over on the first upload of your ride, which is why it wasn’t coming through after you tried re-uploading it.

Hopefully this is just an odd “one-time” issue – but if it persists and continues to happen with your next few rides, please let us know so we can dig deeper into what might be happening!

Hello. Right, possibly I just need to be more patient and wait until image will appear.

But actually this case just make we wonder how Re-Sync works. If for example I will delete my Strava workout created by TrainerRoad by mistake - why Re-Sync not uploads it again? Or probably there is another function under it?

In this case, it’s because past TR workouts won’t automatically sync over to Strava – only your future workouts will.

When we try to reconnect the link between TR and Strava, it’s to “refresh” that connection in hopes that you won’t run into additional problems down the line. Most of the time, it works!

For the ride you had trouble with, though, it’s seen as a past ride, which is why you had to re-upload that specific workout manually.

Thanks, it’s now more clear.
But just for my understanding- what is the difference between disconnect and then connect to Strava in Activity Sync vs Re-sync Ride in Workout?

1 Like

Resyncing/Republishing your ride in the app sends the data from that workout to the TrainerRoad servers so you can view your ride data online (rather than only on your phone/computer offline).

When you complete a TR workout in the app, the data is saved locally in your device. If you happen to be without Internet connection when you finish, clicking “Resync” tries to send that data to our servers anew so you can view your workout on the Internet (on any phone/computer you want).

The TR/Strava Activity Sync link is separate from that. It enables all of your TR workouts to be published to Strava automatically. Sometimes, when rides don’t upload as expected, it can help to disconnect the link between TR and Strava and reconnect it through your Activity Sync page.

Hope that clears it up – let me know if not and I can try to clarify further!