Strava segments not showing on Wahoo head unit

Anyone had problems with starred Strava segments not appearing on their Wahoo head unit? It’s very hit and miss, some segments show up and others don’t. I’ve tried syncing numerous times and uninstalling and installing the ELMT app with no luck. Any ideas?

1 Like

I’ve had similar issues in the past. I played with disconnecting and reconnecting to my wifi and even tried different channels. I never figured out what actually fixed it (since I tried so many things) but I got up to date info after that barrage of attempts.

Is it downhill segments that are not showing up?

Yeah its super frustrating because I can try something and don’t find out if its working till the next ride! :sleepy:

1 Like

Nope, climbs. I’ve not really starred any downhill segments, interesting though - I presume they don’t get pushed due to safety?

1 Like

Yeah, I thought I read something in the past about safety issues and not showing downhill segments. In my opinion a smart move / I don’t see a point for open road downhill segments at all.

As for your issue, sorry, no help from my side. My workflow is going on the Bolt to the route page and click sync. That brings routes and segments up to date for me.

I’ve encountered this too, it seems like the run-up to the segment has to really be “perfect” in some way–ample distance, not too many curves, etc., but I’ve never been able to totally diagnose why it happens with some segments and not with others.

Ive had a lot of trouble with segments on my Roam. It either totally misses them, or half way through the segment it loses it. I gave up.