Stages Power Meter faults after firmware update

Has anyone else had any issues with there stages l/r power meter since the latest update.

Mine has lost all data, classed now as general sensor, got some info back but now no power data been broadcast.

No, mine (3rd gen) is fine with the latest update.

Try installing your battery backwards for 20 seconds. This does a factory reset*. At least it’s worth a try.

*you can also just short the terminals for twenty seconds.

1 Like

I’ll give that a go with the battery in backwards. Am speaking further to stages support tomorrow. The secret swipe didn’t fully work.

Hi RobSmout

Did you have any success with this, randomly my wifes’ left hand side power meters Ant + ID has changed to 1 (rather than being the ANT + ID printed on the label) and is now classed as ‘general’ rather than left sided.

I can’t now pair it to the right hand side power meter, and it doesn’t calibrate either.

I’ve changed the battery, firmware is up to date, and tried the reset, but its not made any difference.

I’ll contact stages in due course but thought I would check in here, as this is the only place I could find that referenced the same kind of issue I am seeing.

all the best

Malcolm

Hi Malcolm,

Did all the data go as well from the tools page, that’s exactly what happened to mine.

I spoke to stages and got a fix to try, it got some data back but not all. It had worked for some people. I’ve now got to send mine to stages to be sorted.

This is what I was told to do.

Connect the left power meter to the Stages power app on an iOS device. You should then see the screen below:

Using one finger swipe right-left-right across the screen over the firmware version once connected to the meter, lift your finger from the screen at the end of each swipe, don’t swipe as one continuous movement.

If successful you should see the screen below:

Then follow the instructions below:

  1. Secret swipe to update firmware to version 0.10.345
  2. Give it a minute after the update process reaches the “verifying” phase, then remove the battery and reinstall in order to force a reset. Do this quickly – If the battery is out for any length of time the process will fail.
  3. Confirm the meter’s data has been restored.
  4. Return to production firmware as normal.

Hi Rob

Yes that is what appears to have happened, the pictures you posted don’t appear to be showing for me, it may be taking a while for them to upload.

Once the pictures load I will have a go, although I suspect I will also be sending back to Stages. Did they give any indication as to what caused it, I did update the firmware about a week or so ago, with no problems, bike not ridden since and this morning is when it happened (I updated the firmware again hoping it would fix it, which it didn’t)

Yeah I did the same, updated, had some connection issues but could connect then a week later it’s a general sensor with data.

Unfortunately not, mines out of warranty so we will see what happens as it was all caused by the firmware update. Well it was fine before that. :grimacing:

Well I followed your instructions and the Ant + ID is no longer 1 but randomly 256. But the crank length is zero and when I calibrate I get 1500, which isn’t right.

I’ve put a support ticket into Stages, so I will see what they say, I am worried about my own unit to be honest, as I updated that around a week or so ago, hopefully that doesn’t do the same.

So at the moment my wife can’t use her right power meter either as without the left one you can’t calibrate (well that seems to be the case anyway)

I think the actual unit is ok, will prob just need stages to flash it with the correct firmware again (fingers crossed)

Thanks for your reply Rob, really helpful, and if any others run into the same problems its a point of reference.

If Stages do manage to sort mine without sending it to them I will follow up here.

Yeah my unit is fine, looks just like something odd in the firmware update. The guy from stages support said I wasn’t the only one this had happened too.

Will update once I know what happens.

Thanks for the factory reset tip

Likewise, thanks again Rob

Malcolm, quick update did a ride today got power from the right crank, cadence and weirdly my smoothness and torque effectiveness both showed up for left not right. Weird. But at least I got cadence and power even though it was based on right only.

Hi Rob

Thanks for the update, I am still waiting to hear from Stages unfortunately and I have just taken the batteries out of the left and right power meters for now. Hopefully stages get in touch this week and I can get the unit shipped to them to sort out. In the grand scheme of things its not a big issue sending the unit in because summer is drawing to an end and the wife will be doing her training on the trainer in the garage.

I’ll update with any progress.

Hi
I have the same issue with the right arm, identify like 1 type general, I just go back to firm 0.10.345, then upgrade and now when calibrate it give me left arm 888 and right arm 1200, I ride and the power was 80% to right arm.

Call Stages, the support site states:

The expected range of values is within +/- 50 from 890, so expect to see numbers in the high 800s or low 900s when calibrating properly.

Ok after having some contact with stages via email I was asked to go through the steps that Rob posted above, which didn’t resolve the issue.

However there is a further ‘developer’ menu available within the iOS app which allows the ANT+ ID etc to be manually changed, Stages support gave me the instructions on how to do this and it now appears that the Power Meter is functioning correctly (correct ANT + ID, device type etc) and I have successfully linked it the right sided power meter and calibrated (both left and right side power meters are on the most recent firmware too)

Stages have asked me not to share the process because it could brick your power meter, so I would recommend reaching out to Stages and they can hopefully get your power meter working.

I’ve yet to try the power meter on a ride, my wife is planning to go out this Sunday (it’s her power meter) so if there are any further issues I will post here.

I have to say Stages have been great, a little slow to reply but thats one of the drawbacks of email support and Covid !

1 Like

Hi Ruben

It sounds like you are experiencing the same issue as Rob and I, which I think is probably related to a recent firmware update that has corrupted the firmware.

I looks like Stages have managed to sort my issues out, so I recommend getting in contact with them, if time is of the essence then I would recommend calling, as its taken around 2 weeks for me to get to a resolution by email.

All the best.

Malcolm

1 Like

Hi all,

I have my power meter back from stages uk distributer. Am putting it back on today to test and see that hopefully it’s all sorted.

Good thing is sent it last Friday got it back in a week.

Unfortunately I haven’t been lucky and the ant + issue is still alive and well in the crank, hoping for the fix ASAP now. It’s a touch frustrating as just got it back. It’s like it wasn’t tested.