Small bug with Import Ride

I found that if I use Import Ride to upload a .zip or .fit file that I’ve exported from Garmin Connect, the import works fine - but it appears not to, because the Import Ride dialog sits there and never disappears. I only realised it had actually worked when I opened another browser tab. I’m using Chrome on Windows 10.

Same with Safari on macOS Catalina.

I suggest emailing so they can review the issue.

1 Like

If someone has a fix please post for mac. It imported my ride on monday but wont do it today. Tried bot fit and tcx files

Has it definitely not worked? The issue I saw was purely cosmetic - the dialog would just spin, but if you opened a separate browser window the import had actually completed.

Today i got nothing

I always have this issue, if left alone the import appears to be hanging. If I click outside in the main TR window the box closes and the import has already completed. Using Win10 + Firefox.

I just started uploading outside rides or a ride i dont do in TR.

How long should a file take. It has only worked for me once manually uploading a file and i have no idea how long it took that time. Im new to this

Per the posts above - if it’s worked, it’ll be almost instant. But it might actually have worked, even if it appears not to have done. If you really can’t get it to work, email the Support folks.

1 Like

I just got home from work, and tried it on my pc nothing. I guess im opening a ticket

So just got done with TR support. Great service. I just found out you cant have two copies of the same ride. I always double record my rides just in case. So My garmin uploaded and the fit file i wanted to load wouldnt load because the garmin file was already in there. I deleted the garmin and the fit file i wanted just up loaded right away, with a screen refresh, Let it spin for 10-20 seconds and then refresh you window then it appears.

Thank you TR support

Road this morning, uploaded file on a mac. Work perfect. Let it spin for 20 seconds then hit screen refresh and it was there.


1 Like

This has got a lot better for me recently, maybe something in one of the updates. No more endless spinny thing.

1 Like