Anyone else having recent problems uploading outdoor ride files from Wahoo Elemnt Bolt?

So for the last ~month I have been unable to manually upload any outdoor ride file generated on my Wahoo Elemnt Bolt. I click on Past Activities and Import Activity, select the file, it churns away, tells me its Completed… but then I see nothing in the calendar for this ride. I can try multiple times and each time it tells me it has completed. Whereas before when I could actually see the ride in my calendar, it would tell me the file is duplicated.

Fair play to the tech team at TR as each time I have sent them an outdoor ride file, they have done a work round and got the file into my calendar. I’ve been advised they are working on a fix, but I don’t feel like I can keep asking every outdoor ride to be uploaded by tech support.

Anyone else got this problem and if so, have you managed to find your own work round? The TR team haven’t advised what their work around is, so I can only presume its something I wouldn’t be able to do at my end.

Yep, here is the response from Traineroad support:
Hey Scott,

Thank you for reaching out to TrainerRoad Support! I’m sorry to hear about the issues you had manually uploading your rides!

Unfortunately, it looks like you may have run into a bug our team is aware of and currently fixing. I’m sorry about that.

Until things are resolved, we do have a workaround for our athletes. The files will upload if they are in another format TrainerRoad accepts besides .FIT. We recommend uploading your .FIT files to Garmin or Strava, converting them to .TCX or .GPX, and then upload them to TrainerRoad.

I appreciate your patience while we get this fixed! Please let me know if you have any questions about that.

Thanks Scott, that’s great! I don’t think I missed it in the responses I got from TR but maybe I did.

What are you using to convert the file from a FIT file? Don’t think the ordinary wahoo app gives me any choice as to what I export the file as.

I didn’t think Wahoo talked to TR at all. I’ve just been entering my outdoor rides manually under “other activities, bike”. The only info I saw was that you needed to use Strava to upload data, and I don’t do Strava. How else can you do it?

Yeah, it’s a bit manual but you export the file from the Elemnt app by going to the History tab, click on the relevant ride, then the three dots to the top right where you get the option to Upload the file [to Strava, TrainingPeaks etc] but instead of any of those just select the Share File To… option. I share it to Google drive (shares as a FIT file), download to my specific device and then use the Import Activities button within the Past Activities section of Trainerroad web app to upload the ride file.

It’s this last bit that isn’t working but it sounds like the work around is to convert the wahoo generated FIT file to a TCX file but that looks easy enough.

Hi, I have also hit this issue. Used to work fine with my old Wahoo Elemnt so thought it may be an issue with my Roam but neither work. I download the Wahoo file to dropbox and import to TR as a .fit file. It says completed but doesn’t display.

I have logged it with support and got the same holding reply. They have been doing the uploads for me manually some how (converting to tcx?)

If converting .fit to .tcx works could you share how to do this please (as long as it’s not too complicated!)

ETA - I’ve sussed out how to do it by using ridewithgps to convert the file!

As an aside, can anyone explain in laymans terms why TR doesn’t interface directly with Wahoo?

Many thanks

@Cycmcyclops do I need an account to use ridewithgps for converting a file?

I haven’t converted any files yet, but google suggested a number of apps/websites.

A job for later on!

@mtbtomo, Yes, you need a ridewithgps account. I have a free one which I use for route planning. I linked my Wahoo to it and it then gives options to download the ride file in various forms - fit, tcx, gpx. I’ve just tested it with tcx and uploaded to TR successfully. Hope that helps.

Likewise, Wahoo Bolt no longer sending the completed outside ride to TR.

(UPDATE: Apologies - this was my problem with Garmin Connect not picking up the ride. All sorted - no longer a problem)

I ran into this over a month ago. Haven’t tried since and surprised it’s still broken. Would have thought fit file uploads would be a core feature :person_shrugging:

Maybe most people sync via some other service

Bit of a faff, but I have been using Garmin Connect (which I use with one of my watches) to upload the wahoo file to and then re download before uploading back in to TR.

I have just bought an Elemnt Roam which uploads no problem, so it can’t be an overall Wahoo problem.

My mistake - it works fine now. Sorry

My mistake - it works fine now. Sorry

No worries, I was referring to the fit file upload itself, nothing to do with outside rides sent to the wahoo head unit.

I probably hit the wrong reply button :smiling_face: